Plex cant read files from Gcrypt

Hello, im trying to setup rclone and need some help here. Would be nice if someone could help me.
I am only using Nzbget, Gdrive and Plex. I am not using Sonnar or something like that.

The Problem i am facing is, that Plex does not recognize my Movies which are stored at my Crypted Gdrive.
Short description of what I want to achieve:

  1. Im using nzbget to download my files
  2. After the Download the completed files gets renamed by filebot and stored to the folder /home/user/uploads
  3. I am mannualy running an upload script which i will list down. (This Script Upload the Files from /home/user/uploads to my Gdrivecrypt) (Mannualy only for testing, later i will make a Cronjob for it)

The first problem i am facing is that all the upload files/folders on my Gdrivecrypt has names like “qqej4o3bdhgfcu5ln2j9nfgfnmtbk”. When i go to Plex and select this folder, then Plex does not recognize them.

I think Plex cant read them because they are crypted.

But how can i make them visible for Plex?

Some of my Settings:


Description=Mount and cache Google drive to Uploads
ExecStartPre=/bin/mkdir -p ${MOUNTTO}
ExecStartPre=/bin/mkdir -p ${LOGS}
ExecStartPre=/bin/mkdir -p ${UPLOADS}
ExecStart=/usr/bin/rclone mount
–log-file ${LOGS}/rclone.log
–log-level INFO
–umask 022
–fuse-flag sync_read
–tpslimit 10
–tpslimit-burst 10
–cache-dir ${UPLOADS}
–config ${RCLONEHOME}/rclone.conf
Gdrive:/Crypted/ ${MOUNTTO}
ExecStop=/bin/fusermount -u -z ${MOUNTTO}
ExecStop=/bin/rmdir ${MOUNTTO}
End rclone.service


type = drive
scope = drive
token = {“access_token”:"…
client_id =…
client_secret = …

type = crypt
remote = Gdrive:/Crypted
filename_encryption = standard
directory_name_encryption = true
password =…
password2 = …

End rclone.conf

Upload Script


RClone Config file

LOCKFILE="/var/lock/basename $0"


Wait for lock for 5 seconds

flock -x -w 5 200 || exit 1

Move older local files to the cloud

/usr/bin/rclone move /home/user/uploads/ Gdrivecrypt: -P --checkers 3 --log-file /home/user/logs/rclone_upload.log -v --tpslimit 3 --transfers 3 --drive-chunk-size 32M --exclude-from /home/user/Scripts/excludes --delete-empty-src-dirs

) 200> ${LOCKFILE}

End Upload Script

You aren’t mounting the crypted remote entry, but the regular GDrive so it’s not decyrpting it.

You want to mount “Gdrivecrypt” instead of the “GDrive” thing.

Those settings seem fairly awful too as I’m guessing they can from some guide out there.

1 Like

Thank you alot! You helped me out :slightly_smiling_face:

You are right i took the rclone.service from an guide.

I replaced it now with the service from your github.

Do i need to make some settings while using your mount script?
Im new to rclone and dont really know which settings are neccesary for my usage.
In your mount Script i dont see settings like :

Are these lines necessary for my benefit?

I am running the whole thing on an cheap 3$ VPS with 2x Intel® Xeon vCores 3 GHz , 2 GB RAM, 45GB SSD.

I changed the rclone.service to:

Description=RClone Service


ExecStart=/usr/bin/rclone mount Gdrivecrypt: /home/user/plex
–dir-cache-time 96h
–drive-chunk-size 32M
–log-level INFO
–log-file /home/user/logs/rclone.log
–timeout 1h
–umask 002
ExecStop=/bin/fusermount -uz /home/user/plex


I’m all about simple so I use many of the default settings where they are applicable.

I really don’t write to my rclone mount so I don’t use vfs-cache-mode writes. That is sometimes needed if you write things from Sonarr and it stores it locally before uploading it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.