Plex can't access mounted google drive

I'm a complete noob so I apologize if any of this seem ignorant or ill-informed.

anyway, I got a pi 4 and set it up - all is good. got Plex media server installed - also all good. rclone is installed - amazing, it's also all good.

the problem is when I want them to all work together. i can't seem to get Plex to "let" me select the mounted google drive. I have the drive mounted to a folder in ym desktop by running

  rclone mount googledrive: /home/pi/Desktop/Drive --vfs-cache-mode full

and the drive appears, as a drive on my desktop. it doesn't hide the Drive folder until it's unmounted like it does on my macOS system, so I'm guessing this is part of the problem too. I open the drive and I can see my files, I can access the pdf perfectly fine. opening up an mkv file seems to either take forever or not work, so I don't try anymore - but I figured since I could access the pdf fine, it was all good.

when I open up Plex and "browse for media" it shows, on the left hand side, I guess an assortment of folders that it guesses would be relevant. I see my Drive FOLDER listed there, but not the drive. when I manually navigate to the desktop, I see only the drive and no folder, but the drive has a file icon next to it and it's entirely greyed out.

any help is thoroughly appreciated.

I can't really nswer the Plex specific question since II don't use that myself (Animosity probably can help you out there later if he reads this) but least tell you the reason your large media files take so long to open is because of full cache mode. in full mode all files will be copied to local cache entirely before they can be read. I do not recommend it for your use case. use write cache if you want to have additional safety on uploads in case of errors. write cache or no cache at all is what you probably want as they actually stream media from the drive unlike full.
Excuse my typos. Unfamiliar mobile keyboard :slight_smile:

ah, that fixed that easily! now to just get to the bottom of why my drive can't be selected.

Try the mount with the --allow-other mount option

1 Like

I feel like an absolute was really that easy. thank you so much, in any case. enough with the headaches.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.