Personal Gmail remote fails lfs to verify, workspace ok

Personal gmail remote fails verification - cannot LFS - error listing: directory not found
Workspace remote is working
I am using service account for personal gmail access as well, since token authorisation failed with error 403: org_internal in the browser, showing:
Request Details
redirect_ [link]//
scope= [correct google drive authorisation scope]
I have tried with --drive-impersonate but then I get "response: {
"error": "unauthorized_client",
"error_description": "Client is unauthorized to retrieve access tokens using this method, or client not authorized for any of the scopes requested.""
Thanks for any help or suggestions


Windows 10 64 bit

Google Drive (personal)

 .\rclone.exe -vv   lsf eslonimGmailDrive:Stuff
type = local

type = drive
client_id =
client_secret =
scope = drive
service_account_file = \\localhost\e$\Temp\rclone-v1.54.0-windows-amd64\rclone-307916-aef1609ada65.json

type = drive
client_id =
client_secret = 
scope = drive
service_account_file = \\localhost\e$\Temp\rclone-v1.54.0-windows-amd64\rclone-307916-aef1609ada65.json
team_drive = 0ADFqVSiTzJ-kUk9PVA
root_folder_id = 

type = drive
client_id =
client_secret = 
scope = drive
service_account_file = \\localhost\C$\Users\Edwin\Downloads\steady-method-308007-768c7c8dc7d2.json

2021/03/18 10:28:11 DEBUG : rclone: Version "v1.54.0" starting with parameters ["E:\\Temp\\rclone-v1.54.0-windows-amd64\\rclone.exe" "-vv" "lsf" "eslonimGmailDrive:Stuff"]
2021/03/18 10:28:11 DEBUG : Using config file from "C:\\Users\\Edwin\\.config\\rclone\\rclone.conf"
2021/03/18 10:28:11 DEBUG : Creating backend with remote "eslonimGmailDrive:Stuff"
2021/03/18 10:28:12 DEBUG : Google drive root 'Stuff': root_folder_id = "0AMC7u2u2Y4ifUk9PVA" - save this in the config to speed up startup
2021/03/18 10:28:13 ERROR : : error listing: directory not found
2021/03/18 10:28:13 DEBUG : 6 go routines active
2021/03/18 10:28:13 Failed to lsf with 2 errors: last error was: error in ListJSON: directory not found

Wasn't sure you can use a service account with a personal gmail as the error seems to state you don't have permissions.

Well I only went that route, because the token authorisation failed with Error 403: org_internal

Is there another way to bypass the interactive login? Or to resolve the Error 403?

You are correct @Animosity022 ! Thanks.

A service account doesn't really allow access to a personal account Drive.

So now I need to solve the Error 403: org_internal - I wonder if my client id is the problem? This is all pretty new to me (using AWS until now).

I'd imagine that's due to the fact your GSuite is internal use only

I don't use a personal account as I only use my GSuite so not sure of what is possible or not these days as it's changed quite a bit.

Ok, I solved the problem - the client-id was from a Workspace account, and the app associated with the client id was not valid for external users. Once I changed that authorisation succeeded, and I was good to go

That would be exactly what I said above :slight_smile:

Not quite, the app used to generate the client-id had the problem, not the G suite itself in any fashion
Thanks for your interest and help

I was referring to your GSuite key being internal as we were talking about client IDs so I thought it was a bit implied.

I can assure you as I'm positive on what I was saying albeit your perception is and can be different.

Fair enough, I accept that - perhaps I didn't think carefully enough about your original response (or about the error code either) :smiley:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.