Permissions regarding a bucket or mount

Hi All,

I’m currently running b2 backblaze bucket using centos 7

Not sure if this is a feature missing or if it’s a bug. I am unsuccessfully attempting to mount a bucket without any permissions to the bucket regarding others, so basically I want 0770 permissions on a bucket either indefinitely or when mounted.

I’ve tried setfacl , chmod when mounted, [and --set-default-permissions , or --umask 770 when mounting]

No error, seems to go through, but it doesn’t stick/save
It always seems to show this when
$ ls -la
d-wxrwxr-x 1 jeremybrown82 jeremybrown82 /mountpoint

but I want this:

d-wxrwx— 1 jeremybrown82 jeremybrown82 /mountpoint

Anyone have an idea?



Hi again All!

Problem Solved!

used the [ --umask 007 ] argument
I was using this before, but I guess I didn’t realize that the bits were inverted



Yes it works the same way as the unix shell umask. A bit strange I agree, but it is a standard parameter for fuse file systems.

1 Like