Performance issue with vfs_cache_mode=full

What is the problem you are having with rclone?

Performance issue with vfs on SSD Disk

What is your rclone version (output from rclone version)

rclone-v1.53.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 8.1 Enterprise, 64 bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

No command, just using the mount to torrent seed usage.

The rclone config contents with secrets removed.

C:\rclone-v1.53.2-windows-amd64\rclone.exe mount drive: C:\gdrive `
--allow-other `
--drive-stop-on-upload-limit `
--drive-acknowledge-abuse `
--cache-dir="V:\z" `
--buffer-size=256M `
--vfs-cache-mode=full `
--vfs-read-ahead=128M `
--stats=1m `
--stats-log-level=DEBUG

I started to notice some performance problems on the SSD drive that host the cache dir with the high average response time on the drive, but nothing being writen\read massively. Other times I get high average response times but 120mb\s writing or reading which is normal

Screenshots in attach:

bad_resmon_1

bad_resmon_2

hi,
--allow-other does nothing on windows....

using the mount for torrents, will hit the cache hard.

Thanks,

Going to remove that flag.

Regarding torrents i completely understand, however it does not explain the high response time from the SSD disk, and when that happens, the activity on torrent client drops to near 0 kbps

well, if the cache is overwhelmed, then the torrent client cannot do anything.

rclone and torrent is not a good mix.

why not download the torrent to local storage and then use rclone move to gdrive

I completely understand that option, however I am trying to understand with people around here if there's not a problem with vfs implementation, because even if the cache is being hit hard, that does not show on resource monitor like the screenshot i just attached. the disk was overloaded with 100% and was only touching apparently 3 files with less then 1mb\s being read.

By this behavior, even if the cache was being "hit hard" we would see different behaviors on read and write speeds, especially when we are talking about an SSD.

Torrents are small reads and scattered.

You have a large bigger size and large read ahead which makes opening and closing things way more intensive.

I’d remove anything you aren’t sure if and use defaults.

I will do some tests with the following config.

C:\rclone-v1.53.2-windows-amd64\rclone.exe mount drive: C:\gdrive `
--drive-stop-on-upload-limit `
--drive-acknowledge-abuse `
--cache-dir="V:\z" `
--vfs-cache-mode=full `
--stats=1m `
--stats-log-level=DEBUG

This is a USB SSD drive, it may not support TRIM or other advanced features. Are you connected with USB 3.x? Also, you show that you are running Windows 8.1, is that correct? Try using a benchmark tool like crystaldiskmark to see what the upper end of performance for this device is really like. Then compare that to what you are seeing with rclone.

If you are seeing poor performance with crystaldiskmark, then I think you need to look to see if there are any driver or firmware updates to your system.