Path json Linux NOK, Windows OK [CLOSE - AUTORESOLVE]


myIT.json is in /root/exploit/rclone/rclone-v1.42-linux-amd64

when I write this path in “Service Account Credentials JSON file path” ->>>

Service Account Credentials JSON file path - leave blank normally.
Needed only if you want use SA instead of interactive login.
service_account_file> /root/exploit/rclone/rclone-v1.42-linux-amd64/myIT.json


Configure this as a team drive?
y) Yes
n) No
y/n> y
Fetching team drive list…
2018/07/02 14:24:08 Failed to configure team drive: list team drives failed: Get oauth2: cannot fetch token: Post unexpected EOF

I tried in a windows environment and it’s ok

I am bad with linux: P

Did you try with the same credentials in Windows? I’m suprised it doesn’t work in Linux if so.

it’s the same file (json) from the beginning

at this moment, windows run without issues
Linux same error :’(

I created a new service account, same issue

Is it possible the file has windows file endings and that is confusing linux? I wouldn’t have thought that would be a problem but it might be worth checking.

If you just copy the config from windows -> linux does it work? Use rclone config file to show where the config is (you’ll need to edit the service file location).

rclone config file => /root/.config/rclone/rclone.conf but in /root/.config/rclone 0 files

Does that mean you found the config file OK? Is it working now?

no, i can’t create the config file , I always have the same issue

What happens if you set it up on windows, copy the config file to unix then edit it to make the service_account_file be in the correct place?

I copied the rclone.config
I put the right path for service_account_file
I can see the different remotes

but I can not create another one, nor use those present

Can you try converting the line endings of the myIT.json file using the howto here:

after a new installation everything is ok
I do not know what is the problem :roll_eyes::face_with_raised_eyebrow::frowning: