--order-by descending modification time doesn't work

What is the problem you are having with rclone?

rclone copy --order-by modtime,desc does not order by time but always transfers alphabetically.

What is your rclone version (output from rclone version)

rclone v1.53.2

  • os/arch: linux/amd64
  • go version: go1.15.3

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04 x64

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy google2: ftp_home: --ftp-concurrency=4 --transfers=1 -vP --drive-service-account-file /opt/sa_fdiaz/1.json --checkers=1 --order-by modtime,desc --include '2020' --syslog

The result was this:

Transferred: 237.996M / 187.601 GBytes, 0%, 9.749 MBytes/s, ETA 5h28m
Transferred: 0 / 8, 0%
Elapsed time: 40.9s
Transferring:

  • Ana (2020)/Ana.2020.10…uRay.REMUX.AVC-iFT.mkv: 1% /21.216G, 9.918M/s, 36m6s^C

The above is not the most recently modified file which is what I expected.

The rclone config contents with secrets removed.

[ftp_home]
type = ftp
host = xxxxxxx
user = xxxxx
pass = xxxxxxx

[google2]
type = drive
scope = drive
team_drive = xxxx
client_id = xxxx
client_secret = xxxx
token = xxxx

A log from the command with the -vv flag

hello,
--include is different between the post and the the log file.

I tried both with and without the filter, same behavior.

For now I just worked around the issue copying one at a time using this

while read path; do rclone copy "union:$path" ftp_home:DATA -vP --ftp-concurrency=4 --transfers=1 -vP --drive-service-account-file /opt/1.json --checkers=1 --syslog ; done < <(find /mnt/unionfs/Remux/Movies/Movies-4K -type f -path '*2020*' -printf "%T@ %Tc %p\n" | sort -nr | grep -Po Remux.*)

If you want perfect ordering, then add the --check-first flag, otherwise rclone will transfer something to get the pipe full even if it is out of order.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.