Option --devname not working

What is the problem you are having with rclone?

I am trying to mount an Amazon S3 drive with rclone like, and I want to name the drive "s3" with the --devname option, but it is not working and it is giving me the drive the default name of "remote:path".

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: darwin 13.1 (64 bit)
  • os/kernel: 22.2.0 (arm64)
  • os/type: darwin
  • os/arch: arm64
  • go/version: go1.19.4
  • go/linking: dynamic
  • go/tags: cmount

I am using the latest rclone version

Which cloud storage system are you using? (eg Google Drive)

Amazon S3

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount s3:bucket/path /Users/user/s3 --vfs-cache-mode full --devname s3

When I run this, the drive is named "s3 bucket path", and not "s3" like I want to.

The rclone config contents with secrets removed.

type = s3
provider = AWS
access_key_id = XXX
secret_access_key = YYY
region = ca-central-1
location_constraint = ca-central-1
server_side_encryption = AES256

Sorry, I actually answered my own question. I realized that I was using the wrong option. The option should be --volname, and not --devname.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.