Operations/copyurl command makes wrong files


#1

Hello.
I am trying to run " operations/copyurl " and I am facing a problem.
Not sure this is whether the rclone issue or my misusing rclone command.

Rclone server is running with " rclone rcd --rc-no-auth --rc-addr=:5572 -vvv " command.
I have run Postman tool to call rest api operations/copyurl.

POST : http://10.111.11.111:5572/operations/copyurl

JSON body: 
	{
	"url": "http://nmap.org/dist/nmap-7.12-1.x86_64.rpm",
	"remote":"myremote:",
	"fs":"myremote:bucket-name/download/"
	}

when i run command from remote server. ( using postman )

The file is downloaded to my buckets, myremote:bucket-name/download/
but the problem is that the name of file is different.
I see the name of the file same as the remote name. In my case, myremote:

so under the myremote:bucket-name/download/ , the file myremote: is created.

I was expecting to have the filename nmap-7.12-1.x86_64.rpm

here is the logs from the rclone rc side.

2019/02/11 20:08:07 DEBUG : rc: “operations/copyurl”: with parameters map[url:http://nmap.org/dist/nmap-7.12-1.x86_64.rpm remote:myremote: fs:myremote:bucket-name/download _async:true]
2019/02/11 20:08:07 DEBUG : rc: “operations/copyurl”: reply map[jobid:1]:
2019/02/11 20:08:07 DEBUG : Using config file from “/home/bbwing/.config/rclone/rclone.conf”
2019/02/11 20:08:07 DEBUG : pacer: Reducing sleep to 0s

so, could this be rclone issue? or I am using the operation/copyurl command wrong ??
any help will be very much appreciated.


#2

What you need to do is put the name of the file you want in the remote parameter, so

{
"url": "http://nmap.org/dist/nmap-7.12-1.x86_64.rpm",
"remote":"nmap-7.12-1.x86_64.rpm",
"fs":"myremote:bucket-name/download/"
 }

Hopefully that will work!