Only allow uploads from cache at night

What is the problem you are having with rclone?

I'm using a rclone mount with VFS cache mode "full" and i want to upload files only at night. I tried to use --bwlimit with a timetable for this (see the command below). Although rclone outputs that the bandwidth limiter is active it still uploads the file after 5 seconds at full line speed. Am i missunderstanding the meaning of 0M:100M?

Thanks for your help!

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.2

  • os/version: debian 11.9 (64 bit)
  • os/kernel: 6.2.16-20-bpo11-pve (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.6
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

2x Onedrive Business through rclone union

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/bin/rclone mount OnedriveUnion: /mnt/onedrive --vfs-cache-mode full --tpslimit 3 --tpslimit-burst 0 --bwlimit "02:00,20M:100M 08:00,0M:100M" --log-level INFO

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[OnedriveUnion]
type = union
upstreams = ONEDRIVE_TB: ONEDRIVE:
search_policy = all
action_policy = mfs
create_policy = mfs

[ONEDRIVE]
type = onedrive
region = global
token = XXX
drive_id = XXX
drive_type = business

[ONEDRIVE_TB]
type = onedrive
token = XXX
drive_id = XXX
drive_type = business

A log from the command that you were trying to run with the -vv flag

2024/03/07 10:31:05 INFO  : Starting bandwidth limiter at 0:100Mi Byte/s
2024/03/07 10:31:05 INFO  : Starting transaction limiter: max 3 transactions/s with burst 1
2024/03/07 10:32:03 INFO  : testfile.out: vfs cache: queuing for upload in 5s
2024/03/07 10:32:16 INFO  : testfile.out: Copied (new)
2024/03/07 10:32:16 INFO  : testfile.out: vfs cache: upload succeeded try #1

As per docs:

The default is 0 which means to not limit bandwidth

Hence all works as expected.

You can not stop uploads completely but maybe you can just limit them to some very low value e.g.:

1B:100M

1 Like

Thanks for your help. I completely missed that detail. I thought "off" would mean unlimited and "0" means zero upload :slight_smile:

Maybe i can prevent uploads by setting --min-size to something very high and setting a lower value via the RC API.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.