Onedrive storage limit mismatch

What is the problem you are having with rclone?

Rclone onedrive limit error

What is your rclone version (output from rclone version)

rclone v1.55.0

  • os/type: linux
  • os/arch: amd64
  • go/version: go1.16.2
  • go/linking: static
  • go/tags: cmount

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 20 Server

Which cloud storage system are you using? (eg Google Drive)

Onedrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

None simple mount of vfs with cache

The rclone config contents with secrets removed.

Onedrive:
Client id
Client secret
Auth url
Token url
Token
Drive id
Drive type Business

A log from the command with the -vv flag

Total: 5T
Used: 2.099T
Free: 144.641G
Trashed: 0

I am using rclone docker image to specify.

My problem is its showing only 144 gb free instead of 2.99tb something.

Something is a little whacky there isn't it.

Can you run rclone about Onedrive: -vv --dump bodies and post the output please?

Are you using OneDrive Personal or Business?

I've seen that behavior with versioning and OneDrive, it won't show the old versions taking up space. I use OneDrive Business so a simple rclone cleanup command fixed it for me and returned my free space.

So i just reinstalled my system to debian and now its working fine strange enough. Also when -r flag is used in onedrive like while deleting. The files are deleted but when i restore them from surface it does show 0KB Usage. But files are perfect fine. Not tried again for new files but around 560 gb is like this. the files were accidentally deleted. could be a bug on MS side.