OneDrive Personal not working


#1

What is the problem you are having with rclone?

After following the official guide for OneDrive Personal configuration with RClone (https://rclone.org/onedrive/) and running the command rclone lsd remote I receive the following errors:
2018/08/08 15:50:59 ERROR : : error listing: directory not found
2018/08/08 15:50:59 Failed to lsd: directory not found
I tried both the automatic configuration answering y to the question
Use auto config?

  • Say Y if not sure
  • Say N if you are working on a remote or headless machine
    y) Yes
    n) No
    y/n> y

and answering ‘n’ and run the code ‘rclone authorize “onedrive”’ in a separate terminal window and feed the result in the token
''Use auto config?

  • Say Y if not sure
  • Say N if you are working on a remote or headless machine
    y) Yes
    n) No
    y/n> n
    For this to work, you will need rclone available on a machine that has a web browser available.
    Execute the following on your machine:
    rclone authorize “onedrive”
    Then paste the result below:
    result> {“access_token”:“EwAgA61DBAAUcSSzoTJJsy+XrnQXgAKO5cj4yc8AARwNyww6+uA/ZDVuUdOig9HfZvnm/4onOxNUfc7dAlt6y6qTv5dUY2oxUlVOp3zsTXuyyxdaJr0T4mqxE+esjPP+1evdVMEZPSJyXEBBy+TjEnRUabjQGwNGiYvbRZwNZ+IhMRnwB6ciIXShJgt+8IAZZMqHc3LwZYzsI2I0523mUFKwWnw2zlh7jccq10UE+fnn6arq6TaUGWaIDoHpDtz7do75fvE1M84SlYmIu9qtfI2ZMm5402DGcdQaBTwqJGwsSgs8quMPJ2jl0A4rxreUXnOWYMx4qjn2PwrArxGLW+cWJln53CIUDYv8mMVGZMpn2G947qLJF0+n1DGvBkkDZgAACPAOvOWoTEQG8AE2EyYeLKIKEo7Tmv5C+vBb3O2AcVvcdaGEm3vjsEvwg00eHArBfsttQvQzqSddPQA1C7Zi7CzT4LkB31wb+PLZZNq7otqAsb+4UITgaWe2G08RDn+vguASv+htsR+ghsisM6rWA/BYXDDb8mpZPZbVCOBZRfNod0C3G5HLhTgEvWyZ/e5q10jNl3hVRxCixa+sE3B3Jle7pY7ZHT6XRmJ/EFm85RiRzdrbzQa9Fvu8cn+BVr9mB3QY+hhNXYcv2BVTrNqA6xxKpIgXDLYZtR1PG4397DUcMG2v42EA1XgeCGd+OsKC5tndrJRHMfQ9zuy6csMpsIJD8c6FCaMuXaxe+WKh/w29QAcnPjmDErrymNlVJDWoKn27hG8kgOqribrDvetjd4/g4wneuZHC5gq40f4/Sg/IklsNSx9QkeAD4oebdvfmkhuZX++MCHK939apq3iO7iW6vvbOcBB60eTshC1XagGp+CreQLEvYPP+Tx4oMaLfTXaMcvqt9Y95Zj1ZesM0/X8amcjX5sxiN/LResoTLZ8sNlKgVDIxFx55Vd77owTDmY7FpPG68iSkcM+2ALtel1wgRx4XC7ysn+Lzn35B0+CzB/DKq45IClzCPhd5aWBCKvjCpfAUkuOKHoA17t1+D6fgBUa3cA2tlxyPHwI=”,“token_type”:“bearer”,“refresh_token”:“MCcUn9js0ofvTFeMoPfCj1eEf66oC8fRY8aH5vQgQdrgcy8zYI0z5t!1GVBcrqMp7epxv3s6gornUbt93TmcjYZOqCQPz5SmjCFAMzIKdmPuSK9sRRwwyYGc1KpvqtlzKcrQCXaOBGIMP7Jo1QSLCL5OEI0JxyaJj0elXS7Q7zRwCg!gnh2BcrkyUVC98LURha19rwPjXymarOjQPJxY66SzJ8iT2ejg5QK5reVZWd!v88o9Xa8wp50eLmNym77ldwA4yadwAqpmgeimvAGcqpHfxoUhoo2!ylEKXIn20kvxo5A531VnZls!sqs*TYjCLunVrGLAfXpX5PNitK!glfJHszwO0h6EgIjwJvwgpvB!f2VDeJ8E74EHXTAuHxbym79gFHeI3zXJwcIqD4Zw$”,“expiry”:“2018-08-08T16:39:36.643181743+02:00”}
    2018/08/08 15:40:35 ERROR : Failed to save new token in config file: section ‘remote’ not found

[remote]
type = onedrive
client_id =
client_secret =
token = {“access_token”:“EwAgA61DBAAUcSSzoTJJsy+XrnQXgAKO5cj4yc8AARwNyww6+uA/ZDVuUdOig9HfZvnm/4onOxNUfc7dAlt6y6qTv5dUY2oxUlVOp3zsTXuyyxdaJr0T4mqxE+esjPP+1evdVMEZPSJyXEBBy+TjEnRUabjQGwNGiYvbRZwNZ+IhMRnwB6ciIXShJgt+8IAZZMqHc3LwZYzsI2I0523mUFKwWnw2zlh7jccq10UE+fnn6arq6TaUGWaIDoHpDtz7do75fvE1M84SlYmIu9qtfI2ZMm5402DGcdQaBTwqJGwsSgs8quMPJ2jl0A4rxreUXnOWYMx4qjn2PwrArxGLW+cWJln53CIUDYv8mMVGZMpn2G947qLJF0+n1DGvBkkDZgAACPAOvOWoTEQG8AE2EyYeLKIKEo7Tmv5C+vBb3O2AcVvcdaGEm3vjsEvwg00eHArBfsttQvQzqSddPQA1C7Zi7CzT4LkB31wb+PLZZNq7otqAsb+4UITgaWe2G08RDn+vguASv+htsR+ghsisM6rWA/BYXDDb8mpZPZbVCOBZRfNod0C3G5HLhTgEvWyZ/e5q10jNl3hVRxCixa+sE3B3Jle7pY7ZHT6XRmJ/EFm85RiRzdrbzQa9Fvu8cn+BVr9mB3QY+hhNXYcv2BVTrNqA6xxKpIgXDLYZtR1PG4397DUcMG2v42EA1XgeCGd+OsKC5tndrJRHMfQ9zuy6csMpsIJD8c6FCaMuXaxe+WKh/w29QAcnPjmDErrymNlVJDWoKn27hG8kgOqribrDvetjd4/g4wneuZHC5gq40f4/Sg/IklsNSx9QkeAD4oebdvfmkhuZX++MCHK939apq3iO7iW6vvbOcBB60eTshC1XagGp+CreQLEvYPP+Tx4oMaLfTXaMcvqt9Y95Zj1ZesM0/X8amcjX5sxiN/LResoTLZ8sNlKgVDIxFx55Vd77owTDmY7FpPG68iSkcM+2ALtel1wgRx4XC7ysn+Lzn35B0+CzB/DKq45IClzCPhd5aWBCKvjCpfAUkuOKHoA17t1+D6fgBUa3cA2tlxyPHwI=”,“token_type”:“bearer”,“refresh_token”:“MCcUn9js0ofvTFeMoPfCj1eEf66oC8fRY8aH5vQgQdrgcy8zYI0z5t!1GVBcrqMp7epxv3s6gornUbt93TmcjYZOqCQPz5SmjCFAMzIKdmPuSK9sRRwwyYGc1KpvqtlzKcrQCXaOBGIMP7Jo1QSLCL5OEI0JxyaJj0elXS7Q7zRwCg!gnh2BcrkyUVC98LURha19rwPjXymarOjQPJxY66SzJ8iT2ejg5QK5reVZWd!v88o9Xa8wp50eLmNym77ldwA4yadwAqpmgeimvAGcqpHfxoUhoo2!ylEKXIn20kvxo5A531VnZls!sqs*TYjCLunVrGLAfXpX5PNitK!glfJHszwO0h6EgIjwJvwgpvB!f2VDeJ8E74EHXTAuHxbym79gFHeI3zXJwcIqD4Zw$”,“expiry”:“2018-08-08T16:39:36.643181743+02:00”}

y) Yes this is OK
e) Edit this remote
d) Delete this remote
y/e/d> y
Current remotes:

Name Type
==== ====
remote onedrive’’

Why I cannot connect to OneDrive?

P.s. Yes, I did call my remote remote

What is your rclone version (eg output from rclone -V)

rclone v1.42

  • os/arch: linux/amd64
  • go version: go1.10.1

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Kubuntu 18.04.1

Which cloud storage system are you using? (eg Google Drive)

OneDrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd remote
or
rclone lsd remote:path

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

marco@marco-Latitude-E7470:~/rclone_OneDrive$ rclone -vv lsd remote
2018/08/08 16:01:26 DEBUG : rclone: Version “v1.42” starting with parameters [“rclone” “-vv” “lsd” “remote”]
2018/08/08 16:01:26 DEBUG : Using config file from “/home/marco/.config/rclone/rclone.conf”
2018/08/08 16:01:26 ERROR : : error listing: directory not found
2018/08/08 16:01:26 Failed to lsd: directory not found


#2

Try typing rclone lsd remote:


#3

You are missing the : off the end of remote: