Onedrive and plex i/o timeout

I can't complete a scan, plex hangs and take up 100% of all my CPUs.
I'm using unraid 6.8.3(linux/slackware), rclone 1.53.3 and Onedrive personal(paid service).

The command I'm using to mount:

rclone mount \
--allow-other --fast-list --transfers 24 --dir-cache-time 2h --drive-chunk-size 256M --log-level INFO --vfs-cache-mode writes --vfs-read-chunk-size 32M --vfs-cache-max-age 1h --vfs-read-chunk-size-limit off --cache-chunk-total-size 4G --cache-chunk-size 16M --cache-chunk-no-memory --cache-workers=24 --buffer-size=256M --max-read-ahead 256M --bind=192.168.2.157 --tpslimit 16 --tpslimit-burst 10 --onedrive-chunk-size 250M

I changed it to this, while playing with the numbers with no luck. I also tried the default setting with just --vfs-cache-mode writes as flag.

--allow-other --buffer-size 3G --vfs-cache-mode writes --vfs-cache-max-age 24h --vfs-cache-max-size 20G --dir-cache-time 1m --cache-dir /mnt/user/media/plex_cache

My config is:, I never change that:

[onedrive_1]
type = onedrive
client_id = some id
client_secret = some secret
token = sometoken
drive_id = someid
drive_type = personal

[onedrive_1_cache]
type = cache
remote = onedrive_1:
plex_url = http://192.168.2.20:32400
plex_username = myuser
plex_password = mypass
chunk_size = 16M
info_age = 1d
chunk_total_size = 10G

I got 4-5 timeout like those with different files in the rclone log before plex hang and takes 100% of all cpus

ERROR : path/name_of_file: ReadFileHandle.Read error: low level retry 1/10: read tcp 192.168.2.20:43158->13.107.42.12:443: i/o timeout

The first IP is mine and the second is a Microsoft one.

p.s. I also created a client_id and secret as you can see in the config using info there:

Any help is much appreciated, Thank you!

hello and welcome to the forum,

i would remove the cache backend, it is depreciated, buggy and not supported
https://rclone.org/cache/#status

instead use
https://rclone.org/commands/rclone_mount/#vfs-cache-mode-full

rclone mount --allow-other --log-level INFO --vfs-cache-mode full --cache-dir /mnt/user/media/plex_cache

with plex, might want to disable these, as this will cause plex to download the entire file duing a scan.

  • Enable Thumbnail previews
  • Perform extensive media analysis during maintenance

Thanx, I tried your suggestion and it wasn't working either... I remove the long file name, and everything is working now.
I added --vfs-cache-max-size 20G to the mount since I have a small cache drive, It was filling up during scan with it absent.
Thanks again, it's cleaner now :wink: