One-Drive Can't Open Office Files

I was looking at rclone as a replacement for the default one-drive program to remove the space it takes on the pc, and for security reasons. I work with a lot of small files including various microsoft office files on windows 10. It seems though with rclone, I can not directly open them from my mounted drive, it just errors out for everything except excel which opens after a long delay. Word gives me "Word had trouble reading form your file. If you are trying to access a file not on your hard drive, please check your internet connection or removable storage and retry." Powerpoint gives me "Sorry, Powerpoint can't read.." Instead I have to first copy them locally, edit them, then take the files and transfer it to the mounted drive. Is that normal, is there a work around? Thanks!

when you posted there was a templates of questions, the answers help us to help you.

Sorry about that, here is the info. I am still having issues with this :frowning:

What is the problem you are having with rclone?

It errors or freezes anytime I directly try to open an office file.

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.0

  • os/version: Microsoft Windows 10 Pro for Workstations 21H2 (64 bit)
  • os/kernel: 10.0.19044.1645 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.17.8
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

One Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount one-drive: Z:

The rclone config contents with secrets removed.

type = onedrive
token = {"access_token":""}
drive_id = 
drive_type = personal

A log from the command with the -vv flag

I dont think I did this right.... 

rclone -vv
2022/05/11 14:32:01 DEBUG : rclone: Version "v1.58.0" starting with parameters ["rclone" "-vv"]
  rclone [flags]
  rclone [command]

Available Commands:

test this
rclone mount one-drive: Z: --vfs-cache-mode=full

1 Like

You fixed it! :smiley: Thanks for the help!
" Without the use of --vfs-cache-mode this can only write files sequentially, it can only seek when reading. This means that many applications won't work with their files on an rclone mount without --vfs-cache-mode writes"
woops haha, thanks!

1 Like

good, it is working now.

fwiw, a debug log would show
ERROR : xyz.docx: WriteFileHandle: ReadAt: Can't read and write to file without --vfs-cache-mode >= minimal

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.