No 'quota exceeded' notice when syncing


#1

Hi. I noticed something that I wanted to know if its a bug or not:
When I hit my daily quota limit on gdrive and try to sync more stuff I don’t get the ‘quota exceeded’ notice as I do when I try to copy under the same circumstances. Instead, it looks like rclone tries to keep syncing anyways.
This is what it looks like:

Is this a bug or not?
Sorry for my poor english, is not my first language.
Thanks in advance.


#2

You can only upload 750GB per day to Google Drive.


#4

Yes, that is correct.


#5

No, it’s not a bug. It’s a google limit. You can limit your bandwidth to prevent hitting the 750GB as an option as well.


#6

Sorry, maybe I wasn’t clear enough, so I will just post screenshots and describe what happens.
When I hit my limit and run rclone copy.
https:// i.imgur.com/Yb8dhGl.jpg

When I hit my limit and run rclone sync.
https:// i.imgur.com/48tuVnL.jpg

As you can see, I only get the quota message when I try to copy.
I’m not claiming that hitting the limit is a bug, I’m saying that the lack of notice after hitting my limit when trying to sync might be.
Thanks.


#7

Rate limit exceeded means you need to slow down as your hitting more than 10 transactions per second. Are you using your own API key or the standard rclone?


#8

Just the standard one.


#9

Yes, those are standard rate limiting messages. You should use your own key if possible and not much to do with those other than turn down your transactions so you don’t do more than 10 per second.