Newbie problem with Google Drive

What is the problem you are having with rclone?

I am have set up a bash script to backup my files on a remote machine to Google Drive. It seems to be working fine but I cannot see anything arriving at Google drive.pi@BS5:~ $ rclone ls ecowremote
886 ChangeLog.txt
18984 directlogin.txt
4 dongle.lock
113 email.txt
1846 SessionLogs/2021-01-30_12-52-43.txt
1666 SessionLogs/2021-01-30_14-40-42.txt
6860 SessionLogs/2021-01-30_14-58-44.txt
277 bolus065535/Data.csv
1183 bolus065535/Log.txt
318 bolus065535/Status.csv
171 CommsDataLogs/Inbound_2021-01-30_12-52-43.txt
44 CommsDataLogs/Inbound_2021-01-30_14-40-44.txt
2861 CommsDataLogs/Inbound_2021-01-30_14-58-46.txt
452 Config/BolusID.csv
3082 Base-Station/
3735 Base-Station/
5085 Base-Station/
10051 Base-Station/
886 Base-Station/ChangeLog.txt
1568 Base-Station/
1486 Base-Station/
1309 Base-Station/
10270 Base-Station/
4493 Base-Station/
2183 Base-Station/
5193 Base-Station/
945 Base-Station/
12233 Base-Station/
15589 Base-Station/
1623 Base-Station/
663 Base-Station/
18984 Base-Station/directlogin.txt
113 Base-Station/email.txt
253 bolus004016/Data.csv
1075 bolus004016/Log.txt
309 bolus004016/Status.csv
453 bolus004014/Data.csv
2360 bolus004014/Log.txt
317 bolus004014/Status.csv
pi@BS5:~ $ ^C
pi@BS5:~ $

But I cannot see them anywhere on Drive - where are they ?

I have just tried to reconfigure to set a named folder pi@BS5:~ $ sh
2021/01/30 15:30:42 INFO : bolus000010/Log.txt: Copied (new)
2021/01/30 15:30:42 INFO : dongle.lock: Copied (replaced existing)
2021/01/30 15:30:42 INFO : SessionLogs/2021-01-30_14-58-44.txt: Copied (replaced existing)
2021/01/30 15:30:42 INFO : bolus000010/Status.csv: Copied (new)
2021/01/30 15:30:42 INFO : bolus004016/Log.txt: Copied (replaced existing)
2021/01/30 15:30:42 INFO : bolus000010/Data.csv: Copied (new)
2021/01/30 15:30:42 INFO : Config/BolusID.csv: Copied (replaced existing)
2021/01/30 15:30:42 INFO : bolus004016/Data.csv: Copied (replaced existing)
2021/01/30 15:30:42 INFO : bolus065535/Data.csv: Copied (replaced existing)
2021/01/30 15:30:42 INFO : bolus065535/Log.txt: Copied (replaced existing)
2021/01/30 15:30:42 INFO : CommsDataLogs/Inbound_2021-01-30_14-58-46.txt: Copied (replaced existing)
2021/01/30 15:30:42 INFO : bolus004016/Status.csv: Copied (replaced existing)
2021/01/30 15:30:42 INFO : bolus065535/Status.csv: Copied (replaced existing)
2021/01/30 15:30:42 INFO :
Transferred: 23.385k / 23.385 kBytes, 100%, 1.951 MBytes/s, ETA 0s
Checks: 36 / 36, 100%
Transferred: 13 / 13, 100%
Elapsed time: 0.0s

I downloaded rclone yesterday - so it should be the latest version.

Please help I am badly stuck.


What is your rclone version (output from rclone version)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

ecowremote does not look like the name of an rclone remote. Best to fill all the information in on the support form. If your remote is called ecowremote, rclone would refer to it as ecowremote:.

Your script might have copied the files to a folder in your home directory and that is what you are listing with rclone ls ecowremote.

1 Like

I have tried to setup a Dropbox folder and It has appeared on the Dropbox site and I can see it from a windows machine on a different netwoork.

But I still get this error message

rclone copy /var/www/Base-Station remote:FarmData
Enter configuration password:
2021/01/30 18:33:11 Failed to create file system for "remote:FarmData": didn't find section in config file
Execute the following on the machine with the web browser (same rclone
version recommended):

rclone authorize "dropbox"

Then paste the result below:
result> {"access_token":"DqbgxENWDsoAAAAAAAAAAYNEvyvkJTv1lIuYKhGiQiYx0rOpX5adgKYpQWfA5S-v","token_type":"bearer","expiry":"0001-01-01T00:00:00Z"}
Current remotes:

Name Type
==== ====
FarmData dropbox
ecowremote drive

e) Edit existing remote

this follows what appeared to be a successful installation although at no pint did I get a screen asking for the token

Please help, I am stuck


try rclone copy /var/www/Base-Station FarmData:

rclone authorize "dropbox"

the remote named dropbox does not exist, you have to use a real remote that you created
rclone authorize FarmData:
rclone authorize ecowremote:

you are an A+ genius! that was all I needed to connect to dropbox. Google drive still gives me problems.

I can go into it and upload direct from the drive (pull) but I cannot seem to push files. I shall stop now and have a look in the morning.

You have put my mind at rest, it does work but there are syntax issues to learn. Now I can automate it.
I am monitoring cows 100 miles away with an IOT device I invented and its a tricky drive there in the Scottish winter to check the system is working.

Thank you again, the documentation was no help, but you have fixed it.

Thank you


thanks, that is kind of you,

the documentation is a living document...

so tomorrow, after checking on the cows, let us know how we can improve it......

Hi again,Dropbox App Client Id
Leave blank normally.
Enter a string value. Press Enter for the default ("").
Dropbox App Client Secret
Leave blank normally.
Enter a string value. Press Enter for the default ("").
Edit advanced config? (y/n)
y) Yes
n) No
y/n> n
Remote config
Use auto config?

  • Say Y if not sure
  • Say N if you are working on a remote or headless machine
    y) Yes
    n) No
    y/n> n
    For this to work, you will need rclone available on a machine that has a web browser available.
    Execute the following on your machine:
    rclone authorize "dropbox"
    Then paste the result below:
    result> rclone authorize "dropbox"
    2021/01/31 08:15:36 Failed to configure token: invalid character 'r' looking for beginning of value
    pi@BS4:~ $ rclone authorize "dropbox"
    2021/01/31 08:16:54 NOTICE: Config file "/home/pi/.config/rclone/rclone.conf" not found - using defaults
    If your browser doesn't open automatically go to the following link:
    Log in and authorize rclone for access
    Waiting for code...
    Got code
    Paste the following into your remote machine --->
    <---End pastepi@BS4:~ $ rclone copy /var/www/Base-Station remote:FarmData
    2021/01/31 08:21:44 Failed to create file system for "remote:FarmData": didn't find section in config file
    pi@BS4:~ $ rclone copy /var/www/Base-Station remote:FarmData
    2021/01/31 08:24:13 Failed to create file system for "remote:FarmData": didn't find section in config file
    pi@BS4:~ $

I pasted the token into the rclone.conf file was that correct ?

it worked easily yesterday but now I am lost again.

help please, I go to the farm tomorrow and I really dont want to have to drive there to get data every day, its snowing again!



      I notice that overnight rclone has lost contact with both Google Drive and dropbox

I seem to be getting the same problem as yesterday about the config file

you have to use the name of a real remote, from the output of rclone listremotes
rclone copy /var/www/Base-Station FarmData:

when testing try rclone ls before using rclone copy

see this post
Failed to configure token: invalid character 'o' in literal true (expecting 'r') - #2 by ncw

another option:
on the computer with the web browser, create the remotes on that.
then copy the rclone.conf file to the headless computer.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.