New Mounting Standard for Google Drive Mounts

So i'm a bit confused, I read that you can no longer mount the old port 5572 -rc way and found this link rclone mount but isn't that only for sftp? Does it work for google drive? Because I tried it and it just said not ready

hi,

when you posted, there was a template of questions, the answers help us to help you.
fwiw, your post is cryptic and hard to understand.

where did you read that, and what command did you try to run?

Ok, does this work?

drive: /mnt/drive fuse.rclonefs config=/opt/rclone/rclone.conf,allow-other,dir-cache-time=1000h,log-level=INFO,log-file=/opt/rclone/logs/rclone.log,poll-interval=15s,umask=002,cache-dir=/data/.cache/drive,vfs-cache-mode=full,vfs-cache-max-size=200G,vfs-cache-max-age=336h,bwlimit-file=16M,uid=1000,gid=1000 0 0

you have to run the command and then you will know if it works.

All it says is bad usage

no idea what it is? please understand, cannot see into your screen.

and there should be a rclone log file, post that.

➜  user mount drive:/ /mnt/drive -t rclone config=/opt/rclone/rclone.conf,allow-other,dir-cache-time=1000h,log-level=INFO,log-file=/opt/rclone/logs/rclone.log,poll-interval=15s,umask=002,cache-dir=/data/.cache/drive,vfs-cache-mode=full,vfs-cache-max-size=200G,vfs-cache-max-age=336h,bwlimit-file=16M,uid=1000,gid=1000 0 0
mount: bad usage
Try 'mount --help' for more information.
➜  user mount drive: /mnt/drive fuse.rclonefs config=/opt/rclone/rclone.conf,allow-non-empty,uid=1000,gid=1000,allow-other,umask=002 0 0
mount: bad usage
Try 'mount --help' for more information.

Doesnt hit a log. /opt/rclone/logs/rclone.log

I mean

drive: /mnt/drive fuse.rclonefs config=/opt/rclone/rclone.conf,allow-non-empty,uid=1000,gid=1000,allow-other,umask=002 0 0

works and it mounts, but i'm not sure what about

drive:/ /mnt/drive -t rclone config=/opt/rclone/rclone.conf,allow-other,dir-cache-time=1000h,log-level=INFO,log-file=/opt/rclone/logs/rclone.log,poll-interval=15s,umask=002,cache-dir=/data/.cache/drive,vfs-cache-mode=full,vfs-cache-max-size=200G,vfs-cache-max-age=336h,bwlimit-file=16M,uid=1000,gid=1000 0 0

doesn't work in fstab because it wont log anywhere for me to see which options aren't working

correct, as rclone is never executed, the issue is with the mount command

as per the docs, did you do
ln -s /usr/bin/rclone /sbin/mount.rclone

yeah i did ln -s /usr/bin/rclone /sbin/mount.rclone
which is why

drive: /mnt/drive fuse.rclonefs config=/opt/rclone/rclone.conf,allow-non-empty,uid=1000,gid=1000,allow-other,umask=002 0 0

works. just not sure why the extra options aren't

well, i would remove all of them, test, add options one at a time.

seems

drive: /mnt/drive fuse.rclonefs config=/opt/rclone/rclone.conf,dir-cache-time=1000h,log-file=/opt/rclone/logs/rclone.log,poll-interval=15s,cache-dir=/data/.cache/drive,vfs-cache-mode=full,vfs-cache-max-size=200G,vfs-cache-max-age=336h,bwlimit-file=16M,allow-non-empty,uid=1000,gid=1000,allow-other,umask=002 0 0

works afterall in fstab

good, it is working now.