New Install Noob help please google to local

#1

Please assist.

So, what I want to do is basically connect my rclone remote called gdrive: to a local mount or share. Basically I would like my software to see the resource as a folder or drive.

Hello, I had set this up one time before but I am having no luck.

I was able to complete the Rclone config and connect my google drive.

Now I would like to make my google drive or in this case my rclone remote visable as a drive or share to applications installed on my local box.

Do you have a document that can point this out. This is a fresh install so I can start all over.

The latest error is:
My remote is called gdrive:

when I type rclone ls gdrive:

I would get

" Failed to ls: googleapi: Error 403: Rate Limit Exceeded, rateLimitExceeded"

[root@wtf02 ~]# rclone mount gdrive: /upload
2019/04/17 23:57:41 mount helper error: fusermount: fuse device not found, try ‘modprobe fuse’ first
2019/04/17 23:57:41 Fatal error: failed to mount FUSE fs: fusermount: exit status 1

Upload is a local directory at /upload.

I have tried running modprobe fuse nothing happens.

#2

So you should make your own client ID / API key if you are able to:

https://rclone.org/drive/#making-your-own-client-id

What OS are you using? It sounds like you need to install fuse so something like:

apt install fuse
yum install fuse
dnf install fuse

Depending on what your OS is.

#3

ok -
I tried to create an app and use the ID and secret but that didn’t work so I just left the fields blank on the second try and I was able to connect my drive.

I am using centos 7-6.1810.2.e17

Linux version 2.6.32-042stab134.3 (root@kbuild-rh6-x64.eng.sw.ru) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-18) (GCC) ) #1 SMP Sun Oct 14 12:26:01 MSK 2018
[root@wtf02 ~]# rpm
RPM version 4.11.3

I did install fuse and checked versions

-bash: RPM: command not found
[root@wtf02 ~]# locate -i -r /fuse
/etc/fuse.conf
/usr/bin/fusermount
/usr/sbin/fuser
/usr/share/doc/fuse-2.9.2
/usr/share/doc/fuse-2.9.2/AUTHORS
/usr/share/doc/fuse-2.9.2/COPYING
/usr/share/doc/fuse-2.9.2/ChangeLog
/usr/share/doc/fuse-2.9.2/FAQ
/usr/share/doc/fuse-2.9.2/Filesystems
/usr/share/doc/fuse-2.9.2/NEWS
/usr/share/doc/fuse-2.9.2/README
/usr/share/doc/fuse-2.9.2/README.NFS
/usr/share/man/man1/fuser.1.gz
/usr/share/man/man1/fusermount.1.gz
/usr/share/man/man1p/fuser.1p.gz

#4

So it looks like you did get fuse install if those files are present.

What’s the actual message you type modprobe fuse?

[root@gemini ~]# modprobe fuse
[root@gemini ~]# lsmod | grep fuse
fuse                  131072  5

You should see the module loaded.

#5

Nothing happens.

#6

You aren’t able to type in the commands and share the output back?

#7

I was able to but nothing happens.

#8

So you can’t copy and paste the terminal output into here?

#9

Oh! sorry.

[root@wtf02 ~]# lsmod
Module Size Used by
[root@wtf02 ~]# lsmod fuse
Usage: lsmod
[root@wtf02 ~]# lmod | grep fuse
-bash: lmod: command not found
[root@wtf02 ~]# lsmod | grep fuse
[root@wtf02 ~]#

#10

and

modprobe fuse does what?

#11

[root@wtf02 ~]# [root@wtf02 ~]#
-bash: [root@wtf02: command not found
[root@wtf02 ~]# modprobe fuse
[root@wtf02 ~]#

#12

How about if you try to reinstall fuse.

yum reinstall fuse

and share what the output of that looks like.

#13

Reinstall 1 Package

Total download size: 86 k
Installed size: 218 k
Is this ok [y/d/N]: y
Downloading packages:
fuse-2.9.2-11.el7.x86_64.rpm | 86 kB 00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : fuse-2.9.2-11.el7.x86_64 1/1
Verifying : fuse-2.9.2-11.el7.x86_64 1/1

Installed:
fuse.x86_64 0:2.9.2-11.el7

Complete!
[root@wtf02 ~]# [root@wtf02 ~]# modprobe fuse
-bash: [root@wtf02: command not found
[root@wtf02 ~]# modprobe fuse
[root@wtf02 ~]#

#14

Yeah, if “lsmod | grep fuse” comes back with nothing, you got something just plain wrong with your OS.

#15

ok, I will reinstall and try again. thank you for your help!