New Feature: vfs-read-chunk-size


#162

I’ll give to direct stream a possibility. In the past i don’t like it too much because is more slow and a little worst quality and it’s not a solution but a workaround.

Maybe i don’t understant at all and don’t want to reopen the argument but if with plexdrive the same plex CLIENT work well maybe is more “simple” that rclone how it store the download chunk.


#163

vfs-read-chunk-size doesn’t store chunks as that’s what the cache does.

The cache backend would be a better fit. If that isn’t working properly for you, open up a new thread and I’m sure the folks here can help out.


#164

Hi all - I’m having trouble figuring out the best settings to get 4K remuxes to play well with my setup. I have a gigabit up/down connection, local 4Ks stream fine off my Windows based server (16GB RAM, quad core, 60TB+ local array).

I have tried the below command and it seems to work for 30mins into a 30mb/s 1080p remux on direct play to a Samsung TV. When i try the below with a 4K remux (70mb/s+), it streams fine for the first 5 mins then starts skipping around the place with extremely choppy playback.

mount Remote: G: --config "C:\[...]\rclone.conf" --allow-non-empty --allow-other --read-only --dir-cache-time 48h --buffer-size 512M --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit 2G

Any idea on how to optimize my Google Drive rclone mount to play nicely with 4K remuxes? I have tried vfs-read-chunk-size as 32M and 512M and both cause buffering ~5mins in.

The above is similar settings to what @Animosity022 was most recently using so not sure what is different between both our setups that is causing the hiccups specifically on high bitrate content.


#165

I handle 70-90 Mb/s 4K Remuxes. My Setup is an emby server + Kodi players.
Do you have a debug mode to see the cache in your player?


#166

Turn off Direct Play and try to stream with the same settings. Let it Direct Stream instead and you should be ok.


#167

If i turn off direct play, the file does not play (it attempts to load, i see my CPU go to 100% transcode then it results in a fail message).

Do you think it could be the samsung player? I could try on another desktop with a 1060Ti (and 1080p monitor) to see if it direct plays in PMP app.


#168

That’s odd. I have the issue with Direct Play on the ATVs and if you turn that off, it Direct Streams and there is like 1% CPU hit. I am not sure why it would go to full transcode over Direct Streaming rather than Direct Play.

Yes, we saw a couple other threads as the player opens and closes the file repeatedly which creates latency since it’s a cloud file and you get the buffer. No real way for rclone to fix that as the player needs to not open/close the file.


#169

interesting, so you think its nothing to do with my settings (specifically, buffer / vfs chunk / cache time)? any idea what i should set it at to be optimal - i may try get an apple tv to test if it works with infuse there.

mount Remote: G: --config "C:\[...]\rclone.conf" --allow-non-empty --allow-other --read-only **--dir-cache-time 48h --buffer-size 512M --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit 2G**


#170

You could try using a proxy before plex as that definitely seemed to work for me. I have some instructions as I used caddy, which is a super simple nice proxy:


#171

Animosity022,

Just curious (maybe I am late to the party) - what purpose does the proxy serve? Does it lead to more reliable streaming speed?

One more question - I am using a copy of your mount settings from earlier in this thread on a VPS but I am struggling with long load times (upwards of 25 seconds). Plexdrive is giving me < 5 seconds. Is there anything in your settings which could be tweaked for a faster load time? Up to 10 seconds is fine, but 25 is kind of long…right? It looks like on your Git page you have since changed some of the values (they look much larger) - is there any danger of replicating those on a low powered VPS?

Thanks!


#172

The proxy mitigates the problem I was seeing with ATV and it repeatedly opening/closing direct play files. With Direct Play the problem goes away with the proxy there.

I had a few folks report it also went away with IOS 12 on the ATV but I have upgraded, but my proxy is still there as it works :slight_smile:


#173

what are the settings ppl are using now? Im on windows so not sure how to fully setup a “proxy”


#174

If you got a few posts up, I linked my config to my github.


#175

The config on the github works well, specially when using a proxy in front of Plex. (Best is to use a proxy in all instances as it’s just set and forget and if using ssl it give you some performance / stability depending on where your server is)

@ctelkes what are the specs of the VPS? I’ve run an earlier version of VFS (and cache) on hetzner VPS ( cx11 and cx21) and even with transcoding it starts within 10 seconds.


#176

Hmm okay so i tried Plex Media Player on a 4K monitor and it seems to be working well…it must be the other player doing what @Animosity022 described as repeatedly opening/closing the file. Will try out with ATV and see how it works once it arrives.

For anyone else reading, this is rclone mounted (not using rclone cache) with the below settings:

mount Remote: G: --config "C:\[...]\rclone.conf" --allow-non-empty --allow-other --read-only --dir-cache-time 48h --buffer-size 512M --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit 2G

Regarding the settings, is there any optimal setting for --dir-cache-time 48h vs. 72h --vfs-read-chunk-size 32M vs. 64M --vfs-read-chunk-size-limit 2G vs. off


#177

For just general playback and such in Plex, I don’t think those settings would matter much. I personally run 32M chunk size / off / 72 hours.

A bigger chunk size would be less API hits but I never come in the realm of close on API hits for a day.


#178

Hmm interesting. So Infuse on my iPhone seems to make 4K buffer via this mount after a few mins…I’m wondering if it will do the same with Apple TV / Infuse.

Is your specific config Google Drive --> rclone mount (non-cache / using VFS settings) --> Plex Direct Stream (disable directplay) on the Plex app?

I want to use Infuse on ATV4K so I can get the HD audio passthrough, do you know if Infuse works without a hitch? My only test case of what works right now is the Plex Media Player on Windows 10 PC with a 10 Series Nvidia GPU (it plays all 4K off rclone mount perfectly).


#179

I currently use a proxy server before plex so I direct play everything if possible as that fixed it for me.

Other than that, all correct.


#180

Gotcha.

I think I got this working well for now, thank you so much for all the help!

I was wondering, I saw some posts about plex partial scan for google drive. Do you know if that can possibly work with windows? it wasn’t fully intuitive to me, especially the instructions part. It would be incredibly helpful if possible to help with this. I don’t use sonarr or radarr for 4K library in the cloud (i.e. items are just uploaded to cloud then read in a separate plex library titled “4K Movies”; for now I just upload files then when a week’s time goes by, I manually “scan library files” for the full library)


#181

In theory it should work but I haven’t touched a Windows machine in 8 or 9 years so I’m not sure offhand how to set that up.