My VFS SweetSpot - Updated 30-Aug-2018


#321

I can’t force that, I’m on the latest version of the repo.

@BinsonBuzz should be on the same version as we are both running Unraid Rclone beta from Waseh. Strange that it works for him and not for me.


#322

I had to add --rc-addr=172.30.12.2:5572 where that’s the IP address of my unRAID server

rclone mount --rc --rc-addr=172.30.12.2:5572 --allow-other --buffer-size 1G --dir-cache-time 72h --drive-chunk-size 32M --fast-list --log-level INFO --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off gdrive_media_vfs: /mnt/user/mount_rclone/google_vfs


#323

Sorry to be annoying. I’m getting this error:

2018/11/06 16:10:42 NOTICE: Serving remote control on http://10.0.0.60:5572/
2018/11/06 16:10:42 Failed to rc: connection failed: Post http://localhost:5572/vfs/refresh: dial tcp 127.0.0.1:5572: connect: connection refused

Rclone mount is:
rclone mount --rc --rc-addr=10.0.0.60:5572 --allow-other --buffer-size 1G --dir-cache-time 72h --drive-chunk-size 32M --fast-list --log-level INFO --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off gdrive_crypt: /mnt/user/mount_rclone/Gdrive --stats 1m &

10.0.0.60 is my Unraid server’s IP

See anything weird?


#324

Have you opened port 5572 open?


#325

Where? In my router?


#326

If you change the port, you have to modify the command running as well as it’s trying to connect back to localhost.

You’d have to add in the:

–rc-addr=IP address you configured


#327

@BinsonBuzz you are also using Pfsense yes?

Did you add a rule on your WAN for port 5572? And did you also put it in port forward under NAT, or not?
Anything else you configured? I keep getting connection refused.


#328

Yep pfsense - if I don’t add 5572 to my list of local allowed ports (between subnets) I get error messages.


#329

Ok I got it to work. I opened the ports on my Pfsense to my Unraid. And I also removed the rc-address part of the mounting since that just caused problems. Now the logging says:

06.11.2018 18:00:55 INFO: installing and mounting rclone.
2018/11/06 18:00:55 NOTICE: Serving remote control on http://127.0.0.1:5572/
{
“result”: {
“”: “OK”
}
}

Seems to be right?


#330

Yep that’s what i get. I’ll try removing the address bit again when I get home, but I definitely needed to open the port on pfsense


#331

If you are running rclone and the commands locally on the same box, where does pfSsense come in?


#332

I’m looking at doing this myself with the --rc command, but do we need to open that port on our router for it to work? Running headless as well.


#333

If you are running the rclone command on the same box as the rc, your firewall/router would not come into play.

If you are running rc and using it a computer on your internal network at home, you wouldn’t need it either.

If you wanted to expose it to the internet, you’d have to turn on auth and port forward on your router (I wouldn’t do that personally).


#334

sorry my fault - for my setup the port needs opening internally to be accessible by other LAN devices


#335

Following that pfsense guide I’m sure I’ll be in the same boat eventually. Thanks for that.