My VFS SweetSpot - Updated 30-Aug-2018


@B4dM4n I’ve never used rc before. I tried doing the commands below but I’m getting errors - am I doing something fundamentally wrong?


rclone mount --rc --rc-addr= --allow-other --buffer-size 1G --dir-cache-time 72h --drive-chunk-size 32M --fast-list --log-level INFO --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit off gdrive_media_vfs: /mnt/user/mount_rclone/google_vfs &

rclone rc --timeout=1h vfs/refresh recursive=true


What errors do you get?

2018/10/23 16:23:37 NOTICE: Serving remote control on
2018/10/23 16:23:37 ERROR : rc: "vfs/refresh": error: couldn't find method "vfs/refresh"
2018/10/23 16:23:37 Failed to rc: Failed to read rc response: 405 Method Not Allowed: {
"error": "couldn't find method \"vfs/refresh\"",
"input": {
"recursive": "true"


You probably use a rclone version smaller 1.43, as Add the vfs/refresh rc command (Fabian Möller) was merged with 1.43. Update your rclone!


nope - I’m on 1.44. my server downloads the latest version everytime I restart and I rebooted yesterday:

root@Highlander:~# rclone version
rclone v1.44-006-gc5ac96e9-beta
- os/arch: linux/amd64
- go version: go1.11.1


Try removing the --rc-addr argument.


Did you restart the mount since you upgraded rclone?
Does rclone rc rc/list show the command?

We should add a core/version command to get the running version of rclone. This would help much in such cases.


Thanks -that did the trick:

2018/10/23 19:00:20 NOTICE: Serving remote control on
"result": {
"": "OK"

I need to work out how to get that to work though as I run a headless server so I can’t easily get to

Yes and yes - prob was above. Need to investigate why


Try the --url argument for the rclone rc command. That should work.



I went do some configuring today and I noticed my /gdrive was not mounted. This is my gcrypt: mount. Trying to mount manually from CLI, I get the following error which is also the error in my rclone log.

2018/10/24 03:58:25 Fatal error: Can not open: /gdrive: open /gdrive: transport endpoint is not connected

I was looking at various forum posts, but not sure where to start. It could be that I need to get some sleep! :rofl:


This should fix it: mkdir /gdrive


hi @Animosity022 can you explain step by step how you configured caddy after the installation? Where you put the caddyfile? have you to register to cloudflare?

Thanks in advance


I don’t use cloudflare for anything other than DNS currently as I found that (for me) going through them slowed things down a little as I have great peering and folks are near me anyway.

I have my actual caddyfile on github along with the systemd start script so other than that, I put it into my /opt/caddy:

felix@gemini:/opt/caddy$ ls -al
total 21396
drwxrwxr-x  4 felix felix     4096 Oct 17 13:59 .
drwxrwxr-x 27 felix felix     4096 Oct 17 13:26 ..
-rwxr-xr-x  1 felix felix 21885856 Sep  2 01:57 caddy
-rw-rw-r--  1 felix felix     1993 Oct 17 13:50 Caddyfile
drwxrwxr-x  2 felix felix     4096 Oct 21 20:43 logs
drwxrwxr-x  4 felix felix     4096 Aug 31 20:32 ssl

and start it up. It does all the SSL stuff automatically and the config file could not be any easier. It just works without doing any extra stuff or having tons of lines of nginx config.

If you are getting any specific issue/error, let me know and I can help out.


It’s already there. I tried to rm -rf /gdrive and recreate it, but I cannot even do that. Also notice that the error shows on ls and permissions and ownership is missing.

kfarris@athena:/$ ls -lrt
ls: cannot access ‘gdrive’: Transport endpoint is not connected
d??? ? ? ? ? ? gdrive
drwxrwxr-x 4 kfarris kfarris 4096 Oct 24 03:25 gmedia


Doing fusermount unmount and re-mounting seems to have fixed it. Any idea why it happened in the first place and why restarting the service did not fix it to begin with?


The service file would probably help. But it looks like the rclone mount was active when rclone was killed. This required you to manually unmount it via fusermount


I’d echo what darthShadow said. It seems like the service file may not be correct or something else was in the directory when it was unmounted.


This is my config

–vfs-cache-mode=writes \

Do you consider it correct?


when i try to launch the service i receive this error:

caddy.service - Caddy HTTP/2 web server
Loaded: loaded (/etc/systemd/system/caddy.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2018-10-26 15:30:44 CEST; 3s ago
Process: 5835 ExecStart=/opt/caddy/caddy -log stdout -agree=true -conf=/opt/caddy/Caddyfile -root=/var/tmp (code=exited, status=226/NAMESPACE)
Main PID: 5835 (code=exited, status=226/NAMESPACE)
ott 26 15:30:44 systemd[1]: Started Caddy HTTP/2 web server.
ott 26 15:30:44 systemd[1]: caddy.service: Main process exited, code=exited, status=226/NAMESPACE
ott 26 15:30:44 systemd[1]: caddy.service: Failed with result ‘exit-code’.

In your caddyfile you put on the top if i dont’ have a dns name can i put my ip?


I’m not sure I’m following what you are trying to do then.

You need a DNS name registered so you can get a SSL cert. Caddy does this all for you, which is why I have use it as it handles doing the cert renews and such rather than using certbot.

For plex, I configure it pointing to a URL and not an IP. I’m not sure how you’d secure it with a IP only unless you setup your own cert or something but not sure how that would work with Caddy.

Caddy simplifies the whole cert process so I take advantage of that as you want all your plex communication to be SSL and not clear text.


so the name plex.animosity is invented and you created it with the caddyfile?