My VFS SweetSpot - Updated 30-Aug-2018


#261

@B4dM4n I’ve never used rc before. I tried doing the commands below but I’m getting errors - am I doing something fundamentally wrong?

Thanks

rclone mount --rc --rc-addr=172.30.12.2:5572 --allow-other --buffer-size 1G --dir-cache-time 72h --drive-chunk-size 32M --fast-list --log-level INFO --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit off gdrive_media_vfs: /mnt/user/mount_rclone/google_vfs &

rclone rc --timeout=1h vfs/refresh recursive=true

#262

What errors do you get?


#263
2018/10/23 16:23:37 NOTICE: Serving remote control on http://172.30.12.2:5572/
2018/10/23 16:23:37 ERROR : rc: "vfs/refresh": error: couldn't find method "vfs/refresh"
2018/10/23 16:23:37 Failed to rc: Failed to read rc response: 405 Method Not Allowed: {
"error": "couldn't find method \"vfs/refresh\"",
"input": {
"recursive": "true"
}
}

#264

You probably use a rclone version smaller 1.43, as Add the vfs/refresh rc command (Fabian Möller) was merged with 1.43. Update your rclone!


#265

nope - I’m on 1.44. my server downloads the latest version everytime I restart and I rebooted yesterday:

root@Highlander:~# rclone version
rclone v1.44-006-gc5ac96e9-beta
- os/arch: linux/amd64
- go version: go1.11.1

#266

Try removing the --rc-addr argument.


#267

Did you restart the mount since you upgraded rclone?
Does rclone rc rc/list show the command?

We should add a core/version command to get the running version of rclone. This would help much in such cases.


#268

Thanks -that did the trick:

2018/10/23 19:00:20 NOTICE: Serving remote control on http://127.0.0.1:5572/
{
"result": {
"": "OK"
}
}

I need to work out how to get that to work though as I run a headless server so I can’t easily get to 127.0.0.1

Yes and yes - prob was above. Need to investigate why


#269

Try the --url argument for the rclone rc command. That should work.

Docs: https://rclone.org/commands/rclone_rc


#270

I went do some configuring today and I noticed my /gdrive was not mounted. This is my gcrypt: mount. Trying to mount manually from CLI, I get the following error which is also the error in my rclone log.

2018/10/24 03:58:25 Fatal error: Can not open: /gdrive: open /gdrive: transport endpoint is not connected

I was looking at various forum posts, but not sure where to start. It could be that I need to get some sleep! :rofl:


#271

This should fix it: mkdir /gdrive


#272

hi @Animosity022 can you explain step by step how you configured caddy after the installation? Where you put the caddyfile? have you to register to cloudflare?

Thanks in advance


#273

I don’t use cloudflare for anything other than DNS currently as I found that (for me) going through them slowed things down a little as I have great peering and folks are near me anyway.

I have my actual caddyfile on github along with the systemd start script so other than that, I put it into my /opt/caddy:

felix@gemini:/opt/caddy$ ls -al
total 21396
drwxrwxr-x  4 felix felix     4096 Oct 17 13:59 .
drwxrwxr-x 27 felix felix     4096 Oct 17 13:26 ..
-rwxr-xr-x  1 felix felix 21885856 Sep  2 01:57 caddy
-rw-rw-r--  1 felix felix     1993 Oct 17 13:50 Caddyfile
drwxrwxr-x  2 felix felix     4096 Oct 21 20:43 logs
drwxrwxr-x  4 felix felix     4096 Aug 31 20:32 ssl

and start it up. It does all the SSL stuff automatically and the config file could not be any easier. It just works without doing any extra stuff or having tons of lines of nginx config.

If you are getting any specific issue/error, let me know and I can help out.


#274

It’s already there. I tried to rm -rf /gdrive and recreate it, but I cannot even do that. Also notice that the error shows on ls and permissions and ownership is missing.

kfarris@athena:/$ ls -lrt
ls: cannot access ‘gdrive’: Transport endpoint is not connected
d??? ? ? ? ? ? gdrive
drwxrwxr-x 4 kfarris kfarris 4096 Oct 24 03:25 gmedia

EDIT:

Doing fusermount unmount and re-mounting seems to have fixed it. Any idea why it happened in the first place and why restarting the service did not fix it to begin with?


#275

The service file would probably help. But it looks like the rclone mount was active when rclone was killed. This required you to manually unmount it via fusermount


#276

I’d echo what darthShadow said. It seems like the service file may not be correct or something else was in the directory when it was unmounted.


#277

This is my config

–vfs-read-chunk-size=2M
–vfs-read-chunk-size-limit=2G
–vfs-cache-max-age=5m
–vfs-cache-mode=writes \

Do you consider it correct?


#278

Hi,
when i try to launch the service i receive this error:

caddy.service - Caddy HTTP/2 web server
Loaded: loaded (/etc/systemd/system/caddy.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2018-10-26 15:30:44 CEST; 3s ago
Docs: https://caddyserver.com/docs
Process: 5835 ExecStart=/opt/caddy/caddy -log stdout -agree=true -conf=/opt/caddy/Caddyfile -root=/var/tmp (code=exited, status=226/NAMESPACE)
Main PID: 5835 (code=exited, status=226/NAMESPACE)
ott 26 15:30:44 ns3027676.ip-5-135-185.eu systemd[1]: Started Caddy HTTP/2 web server.
ott 26 15:30:44 ns3027676.ip-5-135-185.eu systemd[1]: caddy.service: Main process exited, code=exited, status=226/NAMESPACE
ott 26 15:30:44 ns3027676.ip-5-135-185.eu systemd[1]: caddy.service: Failed with result ‘exit-code’.

In your caddyfile you put on the top plex.animosity.us if i dont’ have a dns name can i put my ip?


#279

I’m not sure I’m following what you are trying to do then.

You need a DNS name registered so you can get a SSL cert. Caddy does this all for you, which is why I have use it as it handles doing the cert renews and such rather than using certbot.

For plex, I configure it pointing to a URL and not an IP. I’m not sure how you’d secure it with a IP only unless you setup your own cert or something but not sure how that would work with Caddy.

Caddy simplifies the whole cert process so I take advantage of that as you want all your plex communication to be SSL and not clear text.


#280

so the name plex.animosity is invented and you created it with the caddyfile?