My Recommended Google Drive and Plex Mount Settings - Updated 6-Mar-2019


#586

Thanks for all the help with the screenshots. I am very grateful for the time & trouble the you have taken over this.
When I follow that I do get to the right place although I think that the appearance had changed because I had already created the project & then already enabled the Google Drive API.
I have now plugged in my own Client ID & secret into my .rclone.conf on both my local server & a couple of VPS that I have mounting up the same Google Drive directories.
I’m impressed as I can now smoothly play 30+Mbps Blu-ray Remuxes from my VPS with 15-20 seconds start up time.


#587

It’s 100% good as I want to update the docs but hard to include pics on the docs.

I updated the wording to be more clear in terms of the buttons and such. Does this seem more like what you’d expect or still not quite it?

I can’t recreate from scratch as I already have a project.

1. Log into the [Google API
Console](https://console.developers.google.com/) with your Google
account. It doesn't matter what Google account you use. (It need not
be the same account as the Google Drive you want to access)

2. If there is already a project created for that site, it will automatically take you there. If not and it is your first time, you will most likely need to create a project. Just follow the prompts and give the project a name and that will be your default project.

3. At the top middle of the page, click on "ENABLE APIS AND SERVICES" search for "Drive", and enable the then "Google Drive API".

4. Click the top left and bring up the navigation menu to bring the drown down  and select "APIs & Service -> Credentials"

5. Click on "Create Credentials and select "OAuth client ID".  It will prompt you to set the OAuth consent screen product name, if you haven't set one already.

5. Choose an application type of "Other", and click "Create" using any Name as "rclone" would be fine.

6. It will show you a client ID and client secret.  Use these values
in rclone config to add a new remote or edit an existing remote.

#588

Hello everyone, I need your help.

Recently I moved to new server (i7 7700k, 64gb ddr4, dual 1tb nvme, 1gb up and down) and I am not happy with the playback performance.

For video to start my average is around 10 sec, sometimes more then 20 sec.

My rclone mount looks like this :

rclone mount --rc --rc-addr=xxx.xxx.xxx.xxx:5572 --allow-other --buffer-size 1G --dir-cache-time 72h --drive-chunk-size 32M --fast-list --log-level INFO --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off gdrive: /mnt/ --stats 1m &

This server is only used for media playback, I don’t have any other software install on it such as nzbget, torrent or anything similar. That is also a reason why I don’t use unionfs or anything similar.

I just mount my gdrive to /mnt (gdrive isn’t encrypted) and then add this folders to emby library.

Can you recommend me some settings so playback become faster. My server on average has more then 60gb of ram free, and I am only using 15-20gb of space on my nvme.

When I was setting up a rclone, I created credentials and added during setting up this newly made client Id and secret.


#589

Those settings should be fine.

Can you put the log in debug and hit play and share that?

Are you seeing hits in the API key in the console?

rclone version shows what?


#590

@Animosity022

Looks like you removed the custom buffer setting in your latest update. Is the default working better for you? I’m also wondering what you have your “Transcoder default throttle buffer” in Plex set to. I’ve had mine at 120, but I’m not sure if it makes any difference.


#591

I’ve been toying around with ‘minimal’ settings to see how much impact they make.

99% of my plays are direct play so transcoder buffer doesn’t apply. I think a good happy spot would be anywhere from 300-900 / 5 - 15 minutes at most.

So I’ve noticed 0 difference in playback with using the default buffer size.


#592

Hey Animosity, is mergerfs needed for rclone to run on linux?

When I got rclone running on Ubuntu I followed your workflow from github but I have no idea what mergerfs do and it it’s necessary.


#593

It’s in the name of the tool as it’s like unionFS and ‘merges’ multiple directories into one directory.

I explain my setup at a high level -> https://github.com/animosity22/homescripts#installation as I was going to put some more words to it.


#594

It looks like you aren’t using vfs anymore, what was your reasoning for that? Still not getting any bans when doing scanning on new config?


#595

Why do you think I’m not using vfs?


#596

Maybe I am looking at the wrong script:

I don’t see any mention of VFS unless I am being dumb and missing the obvious, which I must be :-p


#597

I’m using all the default values so no entry is needed.

     --vfs-cache-max-age duration             Max age of objects in the cache. (default 1h0m0s)
      --vfs-cache-max-size SizeSuffix          Max total size of objects in the cache. (default off)
      --vfs-cache-mode CacheMode               Cache mode off|minimal|writes|full (default off)
      --vfs-cache-poll-interval duration       Interval to poll the cache for stale objects. (default 1m0s)
      --vfs-read-chunk-size SizeSuffix         Read the source objects in chunks. (default 128M)
      --vfs-read-chunk-size-limit SizeSuffix   If greater than --vfs-read-chunk-size, double the chunk size after each chunk read, until the limit is reached. 'off' is unlimited. (default off)


#598

I must have missed something then, does 1.46 use vfs by default now?


#599

I think you might be confused as it’s always used VFS as that’s the default.


#600

Yes very confused, haha, I will have to go read more. Thanks for clearing things up :slight_smile:


#601

The default though is no vfs cache.

–vfs-cache-mode CacheMode Cache mode off|minimal|writes|full (default off)


#602

I was getting at the VFS backend is the default that is always used.

It has some caching options as well but those are off by default.

There is a Cache Backend but I am not using that at all and only the default VFS backend with all the default settings currently.


#603

What does the --timeout option do now? I haven’t seen that before and can’t find it documented.


#604

It’s helps with pausing stuff in Plex:

      --timeout duration                             IO idle timeout (default 5m0s)

#605

I’m going to try your setup tomorrow. It looks like a dream! I’ll report back with any issues or questions