Mounting "Computers" (Backup and Sync) with rclone?

I tested it out and it did play a video. It took forever to open the folder that had the videos in it though.

what was the exact mount command?

if you do a speedtest.net, what are the results?

the folder was slow to open, that can be tweaked, could be a windows explorer issue

but the video, did it play without stuttering?

I tried my original command:
rclone mount --vfs-cache-mode full [drive name]:/ [drive letter]:

I then tried it with what you recommended:
rclone mount --read-only [drive name]:/ [drive letter]:

The video played in both instances and didn't stutter but it was only a 30MB video. I tried a higher bitrate video just now that was closer to 3GB and it did stutter, even under the read only command. I got a 10ms ping, 28 mbps down and 6 mbps up in the speed test.

I noticed when I use the vfs command and I try to open a folder containing videos it is writing to my local disk. Is this it filling a cache?

yes, did you read the doc link i shared for full?
"When a file is opened for read it will be downloaded in its entirety first."

if the entire 3GB video was downloaded, it should play without stuttering.
if you download the file to your local computer c: drive and play the video from the c: drive, does it stutter?

about your internet connection, is it 28 mbps` or 28 Mbps?
my download is 780Mbps

Yeah I did. I just found it odd that it would start writing to the local disk when only the folder was opened rather than when the file was played. Maybe to make thumbnails?

It will play without stuttering if download and play it. Windows Explorer seems to be a lot slower at browsing the files when I use the vfs command compared to the read only command.

It's 28Mbps.

in my computational reality, windows explorer is evil, like google is evil.
i have not used windows explorer since windows 98.

@VBB might tell you different......

https://www.justice.gov/atr/file/704876/download
"Microsoft's fusion of Windows Explorer and Internet Explorer may confuse consumers"

but there is a beta version of rclone that might be helpful


you can download the beta from
https://beta.rclone.org/rclone-beta-latest-windows-amd64.zip
and try to use --vfs-cache-mode=full

1 Like

Windows Explorer is pure evil once you have more files and folders in one root folder than it wants you to :). That number, at least in my experience, is around 4,000 to 5,000. That's when it slows down to a crawl, unless the contents are indexed. This can be accomplished by using this command, once the mount is up (note that you have to add --rc to your mount command for this to work):

rclone rc vfs/refresh recursive=true --timeout 10m

Oh, and Jojo, come on, the big G evil, too? How can you say that when most of us use it to store gigglebytes*!!! of data in their service :wink:

*Gigglebyte=hilarious amount of data

I recommend to set view as "Details" ("Small icons" & "List" can be used too) in your Windows Explorer and then apply that view for all folders of the same type (photos only, music only, mixed etc...). Also enabling "Always show icons, never thumbnails" is good alternative. Probably even better but less flexible.

To apply: File -> Options -> View
apply to folders

It helps because it effectively prevents thumbnail generation which consumes quite a lot of data/requests which you don't want. However metadata (properties) are still being read so Windows Explorer may hang if there are lots of files which specific metadata attributes (apart from standard ones for all files like size, creation/access/modification time, etc.) have to be read (e.g.: you enable dimensions for photos or length for videos in your "Details" view). It is possible to disable thumbnail generation and file specific metadata parsing in effect making Windows Explorer very effective while viewing rclone mounts. Although loosing some convienience as that information won't be available to you through Windows Exporer. You can do that with ShellExView (https://www.nirsoft.net/utils/shexview.html) by disabling required property (MF ASF/AVI/MKV/MPEG/MPEG-4 - for video thumbnails and properties; IPropertyStore Handler for Images - for photos) and thumbnail handlers (Photo Thumbnail Provider). Then restarting Windows Explorer to apply the changes. In my opinion photos thumbnailing (Photo Thumbnail Provider) can be left untouched as they don't affect performance that much and you may not know what photo the file contains if it uses general name. Photos metadata (IPropertyStore Handler for Images) should be disabled or you should use viewing mode which doesn't need file specific metadata information. Else, you risk hanging Windows Explorer with folders which have lots of photo files. All those things apply to music, word and other files from which file specific metadata information can be extracted as every file must be read to get that information compared to general file system metadata (file size, modification date etc.) which don't have to be parsed per file basis.

1 Like

To add to the post above, I also found this to be very helpful:

I have the entire mount set to "Documents". That way, Explorer will not show/read any media properties. Unfortunately, if you're dealing with Plex scans, none of this will help :sob:

It creates "desktop.ini" file in specified folder with your viewing settings. So it shouln't work (after next restart) if mount is in --read-only mode.

@asdffdsa @VBB It seems like quite a few questions come in for Windows mounts and there are quite a few tips for it too that are spread across various forum posts.

Something similar like @Animosity022's thread dedicated to Windows mounts would probably be helpful to lots of users.

Would either of you mind creating a dedicated thread for the same to keep everything contained and referenced in it?

1 Like

I'll see what I can do, if I can find the time :slight_smile:

1 Like

Not here. No desktop.ini anywhere, and I use this setting not just with the mount, but also with my entire (writable) D: drive.

It does create "desktop.ini" file if it can though (in the rclone mount too). It is with hidden attribute under Windows NTFS file system so you won't see it if you don't enable showing for hidden files. It seems it is not important file because if you remove it, the last used viewing settings seems to persist. Probably they are stored elsewhere (Windows registry?). Also "desktop.ini" seems to store only the main folder state and does not include information that it applies for its subfolders too.

desktop.ini content example for "Documents" type folder (with and without subfolders enabled):

[ViewState]
Mode=
Vid=
FolderType=Documents

If you made your custom viewing settings and saved them with aforementioned "Apply to Folders", then for e.g. pictures folder would look like the one you set your custom viewing state for actual folder which defaults to picture view. Basically if you changed default picture type folder viewing state and saved with "Apply to Folders", that state will be used for your custom folder type setting (Optimise this folder for: Pictures). So if you add more attributes (columns) to your detail view, you may get Windows Explorer hanging behaviour again as those newly added attributes must be collected. And they are collected more aggressively when you freshly open the new folder with your custom folder viewing state. Too bad that I wrote this simple thing in quite convoluted way :confused:.
TL;DR - Changing folder view settings and saving them with "Apply Folder" makes your changes the new default for that type of folder. So these new settings applies to particular "Optimise this folder for:" folder setting. It may matter to you if you added additional columns with file attributes as that will cause their collection from files. And it may cause the Windows Explorer to hang if there are many files.

also, can try this flag.

 --no-modtime                             Don't read/write the modification time (can speed things up).

No hidden desktop.ini anywhere, on any of my drives (except on the actual desktop on the C: drive, which is normal), local or mounted. Not on Windows Server 2016 and also not on Windows 10. I'm aware that you have to check "Hide protected operating system files" in order to see them.

Every once in a while, I download something that has a hidden desktop.ini, and the only way (without the check mark) I know it exists is after I upload the folder containing it to GDrive. This is because the attribute gets removed.

I tried that a while ago and found it makes no difference, at least not on Windows.

Haha, yes Windows Explorer can certainly be problematic. Although in this case I'm simply trying to achieve the same loading times as Drive File Stream since I've been happy with it until now. Even it can take quite a while to open a folder and load all the content with thumbnails. But rclone is taking much longer for some reason.

Does the --no-modtime have to be by itself or can it be added to the existing read only command?

--no-modtime can help with certain backends.

one thing that for sure can help is @VBB suggestion, vfs/refresh, which he might want to expand on here for you..

go gigglebit yourself :upside_down_face: