Mount very slow e scan Emby very slow


I use Rclone on a server with debian.

A day ago, simply the assembly was removed. So, I've been trying to do a new assembly since yesterday.

It turns out that the assembly process has been underway since yesterday. The files already appear in the folder, but the process is still ongoing on Linux.

I closed the process once due to the delay and restarted the assembly. Only it has more than 12 hours and this montage does not end.

Another problem I have is with the scan of Emby. He's been scanning since yesterday and he's not even halfway through.

What to do to make assembly faster and what to do to make varredura Emby faster?

Currently, I launch this command in the assembly:

rclone mount gdrive: /mnt/**** --allow-other --allow-non-empty

If there is anything I can add to solve all of this, I am very grateful

What is the problem you are having with rclone?

The assembly is taking hours and never finishes. The folders appear mounted, however, the process in linux does not end. Is there a command to speed up the assembly?

What is your version of rclone (result of rclone version)


Which operating system are you using and how many bits (for example, Windows 7, 64 bits)

Debian 10 Buster

Which cloud storage system are you using? (e.g. Google Drive)

Google Drive

The command you were trying to run (for example, rclone copy / tmp remote: tmp)

rclone mount gdrive: /mnt/*** --allow-other --allow-non-empty

hello and welcome to the forum,

the problem is that emby assumes a local file system, to scan the media for thumbnails, intros, previews and so on. rclone has to download all that data from gdrive

there are tweaks that speed up the initial scan.

when you posted there was a template of questions, almost impossible to help you without those answers.......

Sorry. I put the information. Ifare wrong or something is missing please let me know.

I'm doing a new assembly. Now I've added the options: --dir-cache-time 96h --vfs-cache-mode = minimal

Do these options speed up assembly? If not, please tell me what can improve this

as for a rclone mount command, best to copy the settings from here

but that is not really going to help with the initial scan.
you need to tweak emby scan settings to reduce the amount of data it needs to read from the inside of the media files, as rclone has to download the data from gdrive.
or just wait for the initial emby scan to finish.

without a rclone debug log, we cannot know what the real problem is, as gdrive has a lot of limits, as per the rclone documentation.

Again, I tried to do a new assembly and it was more than 10 hours doing the assembly and it didn't finish.

How do I see the rclone logs to post here?

What is an "assembly"?

You need to put --log-file /some/path/rclone.log -vv in your mount command and share the log file.


Google translate

You'd wan to share the full mount command you are using.

With Emby or Plex, if you are changing paths, it has to reanalyze the entire file again so hopefully, you are keeping the paths the same.

How many files are you trying to analyze?
What's your internet speed?

I did not change the path. It remains the same in Emby.

Below is the command I am using at the moment:

rclone mount gdrive: /mnt/**** --allow-other --allow-non-empty --dir-cache-time 96h --vfs-cache-mode=minimal --log-file /home/logsrclone/rclone.log

It never took more than 2 hours to mount. Now it's taking days and the mount doesn't finish. I don't know what may be happening and I don't understand much

rclone mount gdrive: /mnt/gdrive1 --allow-other --allow-non-empty --dir-cache-time 96h --vfs-cache-mode=minimal --log-file /home/logsrclone/rclone.log

If there is something wrong with this command please let me know

Unless you have a great reason, you should not use this. It makes this over mount and hides things.

Why are you using this?

What is in the log file?

Unless you have a great reason, you should not use this. It makes this over mount and hides things.

Okay. I'm going to remove

Why are you using this?

I was reading some topics yesterday, and they said that it helps in reproducing the videos, I can remove it if it is unnecessary. With or without the vfs the problem remains

What is in the log file?

the file remains blank, nothing is written (the rclone has full permission on the folder and the file)

If you want to see what rclone is doing, you'd want to stop your mount.

Add -vv to the mount command and you'll get a debug log file.

That's what we want to look at.

Is this log good or do I have to wait longer?

wait longer for what?
if you want emby to work with gdrive, the rclone mount has to be running all the time.

as for that log file. there is almost nothing it, just a few lines long

the mount is doing nothing at all, idle, not reading, not writing.

does not seem emby is accessing the mount, perhaps the scan is done.
you can check with emby, is it still scanning?

try to play a media file.

Come on!

In the past, when I did the mount, the mount process was active for a while and then ended. However, as I am reporting, now the process is active and does not end.

Then in explains. Is the mount finished yet? Is it normal for this process to be active?


if you want emby to play media file stored gdrive, the rclone mount has to be an active running process.

if you kill rclone, emby cannot see the files in gdrive.

if you want rclone to run as a background process use this flag
--daemon Run mount as a daemon (background mode)

have you tried to play a media file with emby?

Yes, videos play normally.

Do you have any cache settings to recommend? I want to improve the speed of playing videos

i use vfs-cache-mode=off

as for the settings, i shared a link with you ealier in the post.

I want to use VFS and I wanted an example of configuring someone who uses VFS and works well