Mount Not Visible To Application Run In Non-Admin Mode

What is the problem you are having with rclone?

I have a aws s3 mount created in my windows system in admin mode. The drive is not visible in the file explorer, which is absolutely fine.
I have an app that browse for files inside this mounted drive.
The files are only visible if I run the app in admin mode (run as admin). I want the drive and files to be visible in non admin mode also. Please let me know how to achieve this ?

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: Microsoft Windows 10 Enterprise 21H2 (64 bit)
  • os/kernel: 10.0.19044.2728 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

Please check the documentation:

an easy workaround, is what i do.
set the mountpoint to a folder, not a drive letter.

If I set the mountpoint to a folder, then the folder is visible in the file explorer.
I want the following cases

  1. The drive/folder shouldn't be visible to users on file explorer.
  2. The drive/folder should be accessible to applications run in non admin mode.

Please advice.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.