Mount not refreshing

rclone v1.49.5

  • os/arch: linux/amd64
  • go version: go1.12.10

First off pretty new to linux and rclone/mergerfs etc. So thank you for taking time to read this.
I have my Gdrive mounted /home13/indianaguy23/Mount
my MergerFS is /home13/indianaguy23/MergerFS
my Local folder is /home13/indianaguy23/Local

When i add files or when they get downloaded to MergerFS they appear as they should in Local.
When i run the upload script they move from Local to Mount(cloud). My problem is they do not appear in the MergerFS or the "Mount(cloud)" any longer. But they do get uploaded successfully on to my Gdrive(cloud)

the only way i've been able to see them appear properly in MergerFS folder after the upload script is to run the command
systemctl --user restart rclone-vfs.service

For now i've modified my upload script and added the above command. But i know this shouldnt be needed its just a temporary fix for now.

  • What cloud provider do you use?
  • Do you know if you use polling? (knowing your cloud provider will probably tell me though)
  • Does the files appear if you just do a regular F5 refresh?
  • Can you test uploading a small file via the mount - and see if that shows up as expected?

It just sounds like a basic problem of the VFS not being updated (which could indeed happen if you upload outside of the VFS and also do not have polling support). If we can confirm that this is the problem then I can probably suggest some decent workarounds for the problem.

It's google Drive(gsuite)
idk about the polling
Online via Browser files appear and are uploaded to cloud after script.
i would try testing straight to mount but seems i've ran into another problem. suddenly quit working
i've tried to reload daemon restart etc etc
heres what i have now
rclone-vfs.service - RClone VFS Service
Loaded: loaded (/home13/indianaguy23/.config/systemd/user/rclone-vfs.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2019-10-15 03:45:31 CEST; 30s ago
Process: 44861 ExecStart=/home13/indianaguy23/bin/rclone mount RemoteX: /home13/indianaguy23/Mount --allow-other --config /home13/indianaguy23/.config/rclone/rclone.c
Main PID: 44861 (code=exited, status=1/FAILURE)

If you have Gdrive it has polling by default on a mount - unless you specifically disabled it by choice.

That means that every 1min (by default), even if the files were uploaded outside of the VFS, the Gdrive mount will ask the server "did anything change in the last minute?" and get a list in return of changes - which then gets implemented into the VFS cache - and should make your files appear at that point.

Yes, so the problem is definitely that the local cache is not being updated (and is not triggered to know to refresh as needed).

If you enable the RC ( add --rc to mount command) then you can always just force a full update of the VFS with this:
rclone rc vfs/refresh --fast-list recursive=true
and you could just run that at the end of your script. It should only take up to a minute even on a very large collection of files and folders. That should be a decent workaround most likely.

That said, you should not need to do that with this setup (because it has polling support). It may have something to do with how MergerFS works - and have no experience with the details of that system. You may want to ask @Animosity022 for advice as he uses this exact setup (gdrive, mergerfs and upload script). You can also check out his scripts and setup over on the "recommended settings" thread he has. Maybe that will help you pinpoint the problem by comparing your setup to his.

Similarly I can't personally help much with Linux services and daemons. That is too Linux spesific for me to know all the spesific details of as I'm only a Linux novice myself. Hopefully someone else can help.

I will say that a common problem is often that there is an unclean termination that leaves the mount still connected and thus blocking a new one from being started. If that is the case you should try dismounting manually first - then run your usual script and hopefully that works then.
As pr documentation you can use this to dismount manually:

fusermount -u /path/to/local/mount

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.