Mount missing one subfolder

What is the problem you are having with rclone?

I have an rclone ftp mount from my QNAP storage pool into my ubuntu VM (on the same device). Within the mount there's a movie/music/tvshow/other subfolders and about six months ago, music vanished from the mount. I still see it directly on the QNAP filesystem and I still add new music to it, but within the rclone mount in the ubuntu VM it only shows movie/tvshow/other. I've verified on QNAP that all of my media folders have exactly the same permissions and there were no changes at the time it stopped showing. I've also purged the rclone cache, rebooted the VM and the whole QNAP itself to no avail. I hope I've used the template correctly here. Only redacted info is IP Address, Username, and Passwords

What is your rclone version (output from rclone version)

rclone v1.57.0

  • os/version: ubuntu 18.04 (64 bit)
  • os/kernel: 4.15.0-163-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

N/A, ftp mount on same machine

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount container3:Downloads /home/owner/Downloads --allow-other --read-only &

or to isolate

rclone ls container3:Downloads/Completed/Music

The rclone config contents with secrets removed.

type = ftp
host = IP_ADD

A log from the command with the -vv flag

2021/12/11 20:40:01 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "mount" "container3:Downloads" "/home/owner/Downloads" "--allow-other" "--read-only" "-vv"]
2021/12/11 20:40:01 DEBUG : Creating backend with remote "container3:Downloads"
2021/12/11 20:40:01 DEBUG : Using config file from "/home/owner/.config/rclone/rclone.conf"
2021/12/11 20:40:01 DEBUG : ftp://IP_ADD:PORT/Downloads: Connecting to FTP server
2021/12/11 20:40:01 INFO  : ftp://IP_ADD:PORT/Downloads: poll-interval is not supported by this remote
2021/12/11 20:40:01 DEBUG : ftp://IP_ADD:PORT/Downloads: Mounting on "/home/owner/Downloads"
2021/12/11 20:40:01 DEBUG : : Root: 
2021/12/11 20:40:01 DEBUG : : >Root: node=/, err=<nil>

isolated to ls for missing folder:

2021/12/11 20:37:43 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "ls" "-vv" "container3:Downloads/Completed/Music"]
2021/12/11 20:37:43 DEBUG : Creating backend with remote "container3:Downloads/Completed/Music"
2021/12/11 20:37:43 DEBUG : Using config file from "/home/owner/.config/rclone/rclone.conf"
2021/12/11 20:37:43 DEBUG : ftp://IP_ADD:PORT/Downloads/Completed/Music: Connecting to FTP server
2021/12/11 20:37:43 ERROR : : error listing: directory not found
2021/12/11 20:37:43 DEBUG : 2 go routines active
2021/12/11 20:37:43 Failed to ls with 2 errors: last error was: directory not found

Hi noletuary,

Strange issue, have you also tried a native ftp connection from the ubuntu VM to see what it shows?

That is something like this:

> open IP_ADD:PORT
password: PASSWORD
> pwd
> ls
> cd Downloads
> ls
> cd Completed
> ls
> cd Music
> ls
> exit

(The above is based on vague memories and googling, so expect minor mistakes)

hello and welcome to the forum,

rclone can emulate servers such as ftp/www/webdav/sftp/dlna
might test using rclone serve ftp

so Music seems to be missing from there as well, seems like it isn't an rclone issue then

Well, solved.
I ran 'df' and saw the Music folder was mounted separately to another folder. I believe I did this after Music was already not showing up to see if I could mount it elsewhere. Once I unmounted the music folder, it showed back up in my normal mount of all the media folders.

I wouldn't have guessed mounting a subfolder would make all other ftp clients lose access to it, even tried an ftp connection from my laptop. But all is well now.

Happy to hear, well spotted! :sweat_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.