Mount issues and access issues

What is the problem you are having with rclone?

Problems with mounting the folder again. If we are the perfect team to mount this. I need to mount for the fastest possible cache preloading. And how to make this folder available to the website. I wanted to use it as an additional space for the site.

What is your rclone version (output from rclone version)

Screenshot_9

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

 rclone mount gcrypt: ~/media/gdrive --allow-non-empty --cache-db-purge --buffer-size 64M --dir-cache-time 72h --drive-chunk-size 16M --timeout 1h --vfs-cache-mode minimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G

The rclone config contents with secrets removed.

[GD]
type = drive
client_id = 59
client_secret = t8
scope = drive
root_folder_id = 08
token = {"access_token":868
team_drive = 


[gcrypt]
type = crypt
remote = GD:base
filename_encryption = standard
password = 990
password2 = 099
directory_name_encryption = true

Erorr

2021/09/29 22:02:34 mount helper error: fusermount: bad mount point /root/media/gdrive: No such file or directory
2021/09/29 22:02:34 Fatal error: failed to mount FUSE fs: fusermount: exit status 1

hello,

does /root/media/gdrive exist?
what is the output of ls -al /root/media/gdrive?

based on your config file, this does nothing and can be removed
--cache-db-purge

unless you are 100% sure, best to remove --allow-non-empty

add -vv for debug output, to the rclone command, re-run the command and post the entire debug log, not just a snippet.

1 Like

root@v8:~# ls -al /media/gdrive
total 8
drwxr-xr-x 2 www  www  4096 Sep 29 20:41 .
drwxr-xr-x 3 root root 4096 Sep 29 20:41 ..
root@vmi683268:~# rclone mount gcrypt: ~/media/gdrive  --buffer-size 64M --dir-cache-time 72h --drive-chunk-size                              16M --timeout 1h --vfs-cache-mode minimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G -vv
2021/09/30 15:10:09 DEBUG : rclone: Version "v1.56.1" starting with parameters ["rclone" "mount" "gcrypt:" "/roo                             t/media/gdrive" "--buffer-size" "64M" "--dir-cache-time" "72h" "--drive-chunk-size" "16M" "--timeout" "1h" "--vfs-cache-mode" "minimal" "--vfs-read-chunk-size" "128M" "--vfs-read-chunk-size-limit" "1G" "-vv"]
2021/09/30 15:10:09 DEBUG : Creating backend with remote "gcrypt:"
2021/09/30 15:10:09 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2021/09/30 15:10:09 DEBUG : Creating backend with remote "GD:bas"
2021/09/30 15:10:09 DEBUG : GD: detected overridden config - adding "{QEqRK}" suffix to name
2021/09/30 15:10:09 DEBUG : GD{QEqRK}: Loaded invalid token from config file - ignoring
2021/09/30 15:10:09 DEBUG : Saving config "token" in section "GD" of the config file
2021/09/30 15:10:09 DEBUG : GD{QEqRK}: Saved new token in config file
2021/09/30 15:10:10 DEBUG : fs cache: renaming cache item "GD:base" to be canonical "GD{QEqRK}:base"
2021/09/30 15:10:10 Fatal error: Can not open: /root/media/gdrive: open /root/media/gdrive: no such file or directory

different commands use different paths?

  • ~/media/gdrive which is /root/media/gdrive
  • /media/gdrive

i think this might be what you want.
rclone mount gcrypt: /media/gdrive

It doesn't help in any way. I need to be able to mount it calmly and play video materials from this folder.


Screenshot_4

hard to read that tiny teeny screenshot snippet.
best to copy/paste the text.

well, before your command failed to run at all.
seems that you were using a non-existent folder.

now, using the path i suggested, that last rclone mount command seems to be running.

so what is the exact problem now?

It seems to have been mounted, but the command weighs launched as when copying. Will the video still work with this mount, because in this command there is nothing, no-cache, and nothing at all.

root@vmi683268:~# rclone mount gcrypt: /media/gdrive -vv
2021/10/01 10:10:52 DEBUG : rclone: Version "v1.56.1" starting with parameters ["rclone" "mount" "gcrypt:" "/media/gdrive" "-vv"]
2021/10/01 10:10:52 DEBUG : Creating backend with remote "gcrypt:"
2021/10/01 10:10:52 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2021/10/01 10:10:52 DEBUG : Creating backend with remote "GD:base"
2021/10/01 10:10:53 DEBUG : Encrypted drive 'gcrypt:': Mounting on "/media/gdrive"
2021/10/01 10:10:53 DEBUG : : Root:
2021/10/01 10:10:53 DEBUG : : >Root: node=/, err=<nil>

I still can't mount it so I can use it as an additional space for the site

That log shows a working mount.

Why do you think it's mounting?

the only way to know is for you to play a video.
yes, it should play.
when i mount, i do not use the vfs cache flags.

now that the mount works, you can add any flags you want, for example,
i would add --allow-other

rclone mount gcrypt: /media/gdrive -vv --allow-other --buffer-size 64M --dir-cache-time 72h --drive-chunk-size 16M --timeout 1h --vfs-cache-mode minimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.