Mount Issue, i see the share but not files inside

What is the problem you are having with rclone?

Good morning,
after a proper installation and normal use of rclone for days , rclone stopped working no longer hooking the shared share on reboot and especially not being able to manually mount it anymore.
I tried re-editing the configuration repeating all the steps but the result did not change.
I then compared the configuration file with another one that is almost identical ( tokens aside) that I use on a working VM of mine, it still did not work.
I tried deleting the following files
.config/rclone/rclone.conf
/usr/bin/rclone
/usr/local/share/man/man1/rclone.1
and repeat the installation entirely but it still does not work.
In the GUI I see that the gdrive folder is present but inside the files don't show up, even using third party tools like Obsidian to go read the subfolders doesn't work.
All these operations were done on the doriangrey user via sudo

rclone version

rclone v1.66.0

  • os/version: debian kali-rolling (64 bit)
  • os/kernel: 6.5.0-kali3-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.22.1
  • go/linking: static
  • go/tags: none

My storage system is Google Drive

After Installation and configuration I tried to mount my share

sudo rclone mount rclone_remote:'Obsidian Vaults' /home/doriangrey/gdrive --config=/home/doriangrey/.config/rclone/rclone.conf

Even not putting the --config option the result does not change, I put this option in because in troubleshooting at one point it was looking for the configuration file in the root

This is my command with verbose mode

sudo rclone mount rclone_remote:'Obsidian Vaults' /home/doriangrey/gdrive --config=/home/doriangrey/.config/rclone/rclone.conf -vv 

And this is my output, if i change something in original folder the output sees the changes

2024/04/10 08:17:09 DEBUG : rclone: Version "v1.66.0" starting with parameters ["rclone" "mount" "rclone_remote:Obsidian Vaults" "/home/doriangrey/gdrive" "--config=/home/doriangrey/.config/rclone/rclone.conf" "-vv"]
2024/04/10 08:17:09 DEBUG : Creating backend with remote "rclone_remote:Obsidian Vaults"
2024/04/10 08:17:09 DEBUG : Using config file from "/home/doriangrey/.config/rclone/rclone.conf"
2024/04/10 08:17:10 DEBUG : Google drive root 'Obsidian Vaults': 'root_folder_id = 0AAw8zmBmAQMjUk9PVA' - save this in the config to speed up startup
2024/04/10 08:17:11 DEBUG : Google drive root 'Obsidian Vaults': Mounting on "/home/doriangrey/gdrive"
2024/04/10 08:17:11 DEBUG : : Root: 
2024/04/10 08:17:11 DEBUG : : >Root: node=/, err=<nil>
2024/04/10 08:18:11 DEBUG : Google drive root 'Obsidian Vaults': Checking for changes on remote

Post results of:

rclone config redacted rclone_remote:

and

rclone lsf rclone_remote:
[rclone_remote]
type = drive
client_id = XXX
client_secret = XXX
scope = drive
token = XXX
team_drive = 

and

the output of lsf rclone_remote are my all dirs and files in google drive

And

rclone lsf "rclone_remote:Obsidian Vaults"

shows content of this particular remote directory?

sure, my dirs and files :slight_smile:

Your rclone mount log looks perfectly fine and your tests show that remote is working.

Maybe you you run mount as different user than used to access files? In such case you have to provide --allow-other flag. Make sure that you allow it in /etc/fuse.conf - uncomment line containing user_allow_other.

1 Like

i think i love u :smiley: it's working :smiley:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.