Mount freezes while items uploading

What is the problem you are having with rclone?

I currently have a mount set up that manages the uploads to my Gsuite Drive.

The problem is that any time I add anything of any decent size to the mount for uploading, the drive becomes impossible to browse. I have tried both manually dragging and dropping to the mount as well as letting Sonarr manage the copy in the backend.

Sonarr seems to experience the same problem. If I am adding a whole season of a show, a few items will get added to the mount, but then Sonarr errors out and says the paths are missing.

Here is my mount command:

mount upload: Y: --allow-other --cache-dir D:\GCache\Cache --dir-cache-time 72h --drive-chunk-size 64M --log-level INFO --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off --config "C:\Users\user.config\rclone\rclone.conf" --vfs-cache-mode writes

If there are any alterations I can do to make this work better, I'd be incredibly grateful!

Thanks in advance!

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 x64

Which cloud storage system are you using? (eg Google Drive)

Google Drive (GSuite)

The rclone config contents with secrets removed.

type = drive
client_id = xxxxxxx
client_secret = xxxxxx
scope = drive
token = {"access_token":"xxxx","token_type":"Bearer","refresh_token":"xxxx","expiry":"xxxx"}

hello and welcome to the forum,

  • --allow-other does nothing on windows, you can remove it.
  • what version of winfsp?
  • decent size, what does that mean?
  • Mount freezes, what exactly does that mean?
  • you need to post a log with debug info.

It could very well be that uploading to Google Drive saturates your Internet upload. I always limit my uploads by using --bwlimit 95M (this is gig speed, so adjust your limit accordingly). I prefer a "breathing room" of about 5M.

Also, I would advise against uploading lots of files via mount. Copying/moving via command line or RcloneBrowser is much better.

rclone mount is a very convenient way to upload.
much depends on your internet connection.
what is the result of


you might want to check this post. where i solved an issue with slow gdrive on windows by tweaking autotune.

  • --allow-other does nothing on windows, you can remove it.
    Thanks, I'll remove that.
  • what version of winfsp?
    I'm not sure what version of WinFSP. I'll need to check. I initially set everything up about a year ago.
  • decent size , what does that mean?
    I tried uploading two 2.5gb files.
  • Mount freezes , what exactly does that mean?
    I can browse to another directory, but the contents never load and I get a "Not Responding" window.
  • you need to post a log with debug info.
    I'll work on getting the debug info, but since I'm not using commands within rclone directly. would the logs even show?

Thanks for the extra info.

Here are my speedtest results

Ping - 9ms
Down - 921.01 Mbps
Up - 39.77 Mbps

I have Comcast so my upload is terrible, but on the plus side, it may keep my network from being saturated.

Side note - I also have a read-only mount of the same Google Drive and it doesn't get bogged down at all when I am uploading to the first mount.

netsh settings for my system -

TCP Global Parameters

Receive-Side Scaling State : enabled
Receive Window Auto-Tuning Level : normal

yes, as the copying is down via rclone

i think it the opposite, that the slower the upload, the easier it is to saturate.

Thanks! I'll work on getting logs today.

I was also looking at a union mount. Do you think this would help?

This problem should be solved in the beta with the async writeback of uploaded files (with --vfs-cache-mode writes) I think.

1 Like

Thanks, Nick!

I'll check it out!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.