Million+ files, 1 TB data; How do I resume download from GDrive?

What is the problem you are having with rclone?

I have 1 TB of data on Google Drive. Basically, Million+ audio files categorized in thousands of folders. I have a 300 Mbps connection which is pretty stable in normal days. But right now due to some faulty equipment at ISP, connection is very unstable and it will take a week to repair/replace the faulty equipment. I tried to download data using rclone, but connection breaks frequently. I'm able to download somewhat 120 GBs of data in a one go before connection breaks. But when I start again, rclone creates another copy of the same files. I'm using the copy command. I do not want to use the move command. Is there a way to resume the download from GDrive or skip downloaded file? I'm pretty new to rclone.

What is your rclone version (output from rclone version)

  • rclone v1.55.1
  • go/version: go1.16.3
  • go/linking: dynamic

Which OS you are using and how many bits (eg Windows 7, 64 bit)

  • os/type: windows 10 pro
  • os/arch: amd64

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -P copy  "gdrive:/SoundLiberary" "./SoundLib" --progress

The rclone config contents with secrets removed.

type = drive
client_secret = REMOVED
scope = drive
token = {"access_token":"REMOVED","token_type":"Bearer","refresh_token":"1//REMOIVED-REMOVED","expiry":"2021-05-12T19:49:00.0712887+05:30"}

A log from the command with the -vv flag


hello and welcome to the forum,

rclone does not re-download the same file over and over again.
as per the docs
"Copy the source to the destination. Doesn't transfer unchanged files, testing by size and modification time or MD5SUM"

without a debug log, no way to know what is going on.

Thanks for the reply.
I recreated app on google app console. and reconfigured rclone and now everything works as intended.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.