Mergerfs service stops working

What is the problem you are having with rclone?

My mergerfs folder appears blank every few days and the only way to resolve this is by restarting the rclone service and mergerfs service. Im not sure why this is happening and if someone could kindly assist me. I will provide further information when requested.

The system i am using is a seedbox running debian rclone version is v1.58.0.

When the folder goes blank plex, sonarr, radarr stops working because it is setup to use mergerfs for media when i check the service status there are no errors.

Run the command 'rclone version' and share the full output of the command.

sheldon@kallisto:~$ rclone version                                              rclone v1.58.0                                                                  - os/version: debian 10.10 (64 bit)                                             - os/kernel: 4.19.0-17-amd64 (x86_64)                                           - os/type: linux                                                                - os/arch: amd64                                                                - go/version: go1.17.8                                                          - go/linking: static                                                            - go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

sheldon@kallisto:~$ cat ~/.config/rclone/rclone.conf [gdrive] type = drive client_id = xxx client_secret = xxx
scope = drive root_folder_id = 1MFK0o6yo8FBVi-H4ivjnrogN8Zhg-EL9
token = xxx
team_drive =

A log from the command with the -vv flag

Paste  log here

What command do you use to start?

As per ultraseedbox's forum for rclone i use

systemctl --user start --now mergerfs.service

When it goes blank, check the the things mergerfs is merging (eg the rclone mount) and see if they are working. This will give a clue as to whether it is rclone going wrong or mergerfs

The mergerfs service hasn't failed but the dir is blank again.

The remote dir remains active and shows the files only mergerfs and local dirs are blank so far the only way to resolve this is to restart both services.

Did you mean the rclone mount is working OK here?

Yes the rclone mount still works only mergerfs mount and local mount is blank

The only way to fix this is to restart both services

As mentioned earlier i can see the files in the rclone mount directory called remote

Mergerfs mount directory is called mergerfs
Local mount directory is called local

Do you have any log files to share? Systemctl logs? rclone logs? Anything to show the broken state?

When it happened i checked systemctl status and the service was active with no errors.

How do i get logs for the service?

The rclone logs only show errors for Limit exceeded

What do you mean by the local mount? Are you running rclone mount to mount a local directory? You don't need to do that, just use the path to the directory in the config.

Mergerfs have a service file.

Can you share your service file?

To get a journalctl log, I'm not sure with a user service, but I'd assume it's the same:

journalctl -u servicename.service -b

That gets all the logs since boot.

For rclone, you need to run it in debug log -vv --log-file /your/home/dir/rclone.log

and recreate the issue and share all the logs fore the relevant time period.

The local mount is used for the upload script

Service file for mergerfs

Am i able to do the debugging option on the rclone service file because the problem only occurs once a week.

I followed instructions to create the service files using Rclone VFS and MergerF... | Docs

Description = MergerFS Service                                                  
ExecStart=%h/bin/mergerfs \                                                     
    -o use_ino,func.getattr=newest,category.action=all \                        
    -o category.create=ff,cache.files=auto-full,threads=8 \                     
    %h/local:%h/remote %h/mergerfs                                              
ExecStop=/bin/fusermount -uz %h/mergerfs                                        

This is the only entry in the mergerfs mount log

bin/fusermount: entry for /home43/sheldon/mergerfs not found in /etc/mtab

Can you share the full output of the commands like journalctl?
Can you share the rclone service file?
Can you share the journalctl of the rclone service as well?

The more you can share with full logs, the quicker we can get to a solution.

Journalctl logs since boot for both services

sheldon@psyche:~$ journalctl -u rclone-vfs.service -b                           Hint: You are currently not seeing messages from other users and the system.          Users in groups 'adm', 'systemd-journal' can see all messages.                  Pass -q to turn off this notice.                                          -- No entries --                                                                You have new mail in /var/mail/sheldon                                          sheldon@psyche:~$ journalctl -u mergerfs.service -b                             Hint: You are currently not seeing messages from other users and the system.          Users in groups 'adm', 'systemd-journal' can see all messages.                  Pass -q to turn off this notice.                                          -- No entries --                                                                

Rclone service file copied from my seedbox providers document page Rclone VFS and MergerF... | Docs

Description=RClone Service                                                                                                                                              
ExecStart=%h/bin/rclone mount gdrive: %h/remote \                               
  --config %h/.config/rclone/rclone.conf \                                      
  --dir-cache-time 1000h \                                                      
  --use-mmap \                                                                  
  --poll-interval=15s \                                                         
  --vfs-cache-mode writes \                                                     
  --poll-interval=15s \                                                         
  --tpslimit 10                                                                 
ExecStop=/bin/fusermount -uz %h/remote                                          

The problem is that there is nothing in any of the log files so i cant provide much info

Why have you got this set? I suggest you remove this line as it could be the cause of inexplicable lockups with rclone mount (it is a long story!).

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.