MergerFS - /local /mergerfs / mount (gdrive)

Hi All,
I have an issue with my mergerFS configuration, I suspect its me being un experienced in is use, but I seem to be 99% there with it.

I have the following mergerFS settings :
/volume1/General/rclone/local (local mirror drive)
/volume1/General/rclone/mount (My gdrive mount)
/volume1/General/rclone/mergerfs (combination of the above two) My applications like Radarr, Sonarr and Plex all point here.

My script runs:
mergerfs -o defaults,sync_read,auto_cache,use_ino,allow_other,func.getattr=newest,category.action=all,category.create=ff /volume1/General/rclone/local:/volume1/General/rclone/mount /volume1/General/rclone/mergerfs

The issue i'm having is after Radarr processes the media, I am expecting to see the media in /Local for my script to upload, but what is happening is the media is visible in /mergerFS and /mount and not in local.
Is the mergerfs command in the correct order for my setup? I don't understand how the media is showing on my mount folder (gdrive) without uploading, unless radarr is moving directly there.

I think its probably a simple error on my part, but I can't put my finger on it.

You got a mix of paths? Not sure if that's on purpose:

You say that, but you got:

/rclone/local would not be the same /volume1/General/rclone/local

Which is the right one in your setup?

Mine looks like:

ExecStart=/usr/bin/mergerfs /cache:/GD /gmedia -o rw,use_ino,allow_other,func.getattr=newest,category.action=all,category.create=ff,cache.files=partial,dropcacheonclose=true

and you can do a simple test with a touch of a file.

felix@gemini:~$ cd /gmedia/
felix@gemini:/gmedia$ touch test
ls -felix@gemini:/gmedia$ ls -al /cache/test
-rw-rw-r-- 1 felix felix 0 Oct  9 12:35 /cache/test
felix@gemini:/gmedia$ ls -al /gmedia/test
-rw-rw-r-- 1 felix felix 0 Oct  9 12:35 /gmedia/test

To validate it is creating it in the right spot.

Hey Ano, all the paths are /volume1/General/rclone/ I just didnt type the full paths in at the top of my post.

touch test creates a text file in mergerfs and this text file appears in local, so it ll seems to be working correctly, not sure then why media from radarr isn't working in the same manner,

Radarr points to -v /volume1/General/rclone/mergerfs/media:/media \

edit: a media folder was created in local as you would expect, but the newly downloaded media only appears in mergerfs and mount folders. I'll try another, see if it behaves the same or not

That's not a valid path.

Its in my docker config as that, and adding the path in radarr has correctly populated my media / covers exc, why is it not valid?

It just appears as /media when i open up explorer in radarr to point to.

I didn't know you were using docker as you didn't mention it until now.

I can't follow what paths you got going on as you keep changing around and adding different things so it's really tough to assist.

Good luck!

1 Like

Thanks for looking :slight_smile: I adjusted the paths in my first post, apologise for the confusion,

Think I found the issue, the usual one, permissions. I have to grant system permission on the synology to the /local and /mergerfs folders, the mergerfs has to be run as root on command prompt, operation not permitted otherwise. When mergerfs is run as root it is clearing the system permission on the synology for some reason..

Its defaulting to give the follwoing permissions on the synology:-

Note no write access. Maybe another flag is the mergerfs command