Mergerfs > 2.25 seems to not work with rclone

I opened up an issue over on the mergerfs github.

The issue is here:

Rolling back to 2.25 seems to work just fine again. Gong to see if I can figure out what is needed to make it work.


@ncw or @B4dM4n - any thoughts?

Broken log:

I changed my mount option as defaults was removed from 2.26 on and this seems to work:

[root@gemini system]# cat gmedia.mount
Description = /gmedia MergerFS mount

What = /data/local:/GD
Where = /gmedia
Type = fuse.mergerfs
Options = rw,sync_read,use_ino,allow_other,atomic_o_trunc,auto_cache,big_writes,default_permissions,splice_move,splice_read,splice_write,func.getattr=newest,category.action=all,category.create=ff


The final fix in the code was a new flag added.

You'd need to build from github until the release is added:


async_read=false takes the place of sync_read.

I made an issue in rclone too, to explore fixing this in rclone without the flag which will in general make the FUSE stack compatible.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.