Md5sum is not working with S3 on 1.40

I’ve upgraded to clone 1.40 and found that md5sum is not working on a crypt remote. It’s reporting “UNSUPPORTED” for all files.

I’m running the following command. I get the same result with or without “–fast-list”.

rclone md5sum --fast-list --verbose encryptedremote:path

If I go back to 1.38 it returns a blank entry for all files on the encrypted remote.

md5sum has never worked on a crypt remote. At some point rclone became a bit more consistent about showing empty (meaning I don’t have an md5sum for this file) or “UNSUPPORTED” meaning no files have md5sums on this remote.

I was going off of another thread where cryptcheck was reporting “X hashes could not be checked”. The recommendation was to find files that were missing a hash. Now that I reread the post I see the recommendation was to check for a sha1sum and not a md5sum. :laughing: Unfortunately I see the same output with sha1sum, “UNSUPPORTED”.

Alas crypt doesn’t support any hashes at the moment :frowning:

That is why cryptcheck was born.

Thanks for clarifying @ncw. If I can just sort out the files that are failing to cryptcheck I’ll be golden.