cloud: "failed to authorize: oauth2: server response missing access_token"

What is the problem you are having with rclone?

Recently rclone stopped working with mail ru cloud with the following message:

$ rclone lsd mailru:
2022/10/25 23:13:39 Failed to create file system for "mailru:": failed to authorize: oauth2: server response missing access_token

The same command used to work three months ago (August 2022).

rclone version v1.60.0 (latest at the moment)

  • I have not enabled 2FA, I am aware that is should not be enabled (see #3637 and #3988).
  • I haven't changed password nor changed anything in mail ru security.

hello and welcome to the forum,

can you post the full output of rclone lsd mailru: -vv

might try rclone config reconnect mailru:
create a new remote using rclone config

Here it goes (the password is deliberately hidden):

$ rclone lsd -vvv --dump headers,bodies mailru:                                            
2022/10/26 10:00:44 DEBUG : rclone: Version "v1.60.0" starting with parameters ["rclone" "lsd" "-vvv" "--dump" "headers,bodies" "mailru:"]  
2022/10/26 10:00:44 DEBUG : Creating backend with remote "mailru:"                                                                          
2022/10/26 10:00:44 DEBUG : Using config file from "/home/dma_k/.config/rclone/rclone.conf"                                                
2022/10/26 10:00:44 DEBUG : You have specified to dump information. Please be noted that the Accept-Encoding as shown may not be correct in 
the request and the response may not show Content-Encoding if the go standard libraries auto gzip encoding was in effect. In this case the body of the request will be gunzipped before showing it.                                                                                     
2022/10/26 10:00:44 INFO  : []: Valid token not found, authorizing.                                                                         
2022/10/26 10:00:44 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>                                                    
2022/10/26 10:00:44 DEBUG : HTTP REQUEST (req 0xc00017c300)                                                                                 
2022/10/26 10:00:44 DEBUG : POST /token HTTP/1.1                                                                                            
User-Agent: rclone/v1.60.0                                                                                                                  
Content-Length: 86                                                                                                                          
Content-Type: application/x-www-form-urlencoded                                                                                             
Accept-Encoding: gzip                                                                                                                       

2022/10/26 10:00:44 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2022/10/26 10:00:44 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2022/10/26 10:00:44 DEBUG : HTTP RESPONSE (req 0xc00017c300)
2022/10/26 10:00:44 DEBUG : HTTP/2.0 200 OK
Content-Length: 111
Cache-Control: no-cache,no-store,must-revalidate
Content-Type: application/json;charset=UTF-8
Date: Wed, 26 Oct 2022 08:00:44 GMT 
Expires: Tue, 26 Oct 2021 08:00:44 GMT
Last-Modified: Wed, 26 Oct 2022 11:00:44 GMT
Pragma: no-cache
Server: nginx
Strict-Transport-Security: max-age=31536000; includeSubDomains; preload
X-Frame-Options: DENY
X-Mru-Request-Id: a2427891

{"error":"invalid username or password","error_code":3,"error_description":"username or password is incorrect"}
2022/10/26 10:00:44 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2022/10/26 10:00:44 Failed to create file system for "mailru:": failed to authorize: oauth2: server response missing access_token

By looking into the log I understood the confusion of Cloud: “Failed to authorize: oauth2: server response missing access_token” instead of “username or password is incorrect”.

I tried it when found the ticket #6398, but it seems that this backend does not support reconnect.

I have created a new remote and it fails with the same error. I think I miss some details in all this story. 2FA is certainly disabled, however I have application-specific passwords (generated long time ago) – probably that started to play a role the last time.

The integration tests for mail ru started falling in the same way recently.

I think the api must have changed somehow.

I'll reopen the issue above - please write anything you find out there.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.