Locked files are deleted on sync with S3 on Windows

What is the problem you are having with rclone?

Hello guys!
In Windows rclone has a serious issue when changes occur in locked files on a S3 drive (for instance Word documents opened directly from the drive). After "Save" the file is DELETED on S3 and later it disappears locally.


  1. Mount a S3 drive
  2. Store a Word docx file on the drive
  3. Open the file, change something and save. Leave the file open for a minute
  4. Close Word
    Result: The file is deleted.

What is your rclone version (output from rclone version)

rclone v1.52.3

  • os/arch: windows/amd64
  • go version: go1.14.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10, 64 bit

Which cloud storage system are you using? (eg Google Drive)

Amazon S3

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone.exe mount blabla:blabla/ Y: --vfs-cache-mode writes -v

Also tried the other VFS cache modes with no success (except maybe for the "off" mode which invalidates the scenario).

The rclone config contents with secrets removed.

type = s3
provider = AWS
env_auth = false
access_key_id = secret1
secret_access_key = secret2
region = eu-west-1
location_constraint = eu-west-1
storage_class = STANDARD

A log from the command with the -vv flag

c:\rclone>rclone.exe mount blabla:blabla/ Y: --vfs-cache-mode writes -v
2020/09/22 18:17:17 INFO  : S3 bucket blabla: poll-interval is not supported by this remote
2020/09/22 18:17:17 INFO  : Cleaned the cache: objects 11 (was 0), total size 488.485k (was 0)
The service rclone has been started.
2020/09/22 18:18:15 INFO  : folder1/folder2/2020/test/yv_bg6.docx: Copied (replaced existing)
2020/09/22 18:18:17 INFO  : Cleaned the cache: objects 11 (was 11), total size 488.175k (was 488.485k)
2020/09/22 18:18:25 INFO  : folder1/folder2/2020/test/~WRD0002.tmp: Copied (new)
2020/09/22 18:18:25 INFO  : folder1/folder2/2020/test/yv_bg6.docx: Renamed in cache
2020/09/22 18:18:25 INFO  : folder1/folder2/2020/test/~WRD0002.tmp: Renamed in cache
2020/09/22 18:18:26 INFO  : folder1/folder2/2020/test/yv_bg6.docx: Copied (server side copy)
2020/09/22 18:18:26 INFO  : folder1/folder2/2020/test/~WRD0002.tmp: Copied (server side copy)
2020/09/22 18:18:26 INFO  : folder1/folder2/2020/test/yv_bg6.docx: Deleted
2020/09/22 18:18:26 INFO  : folder1/folder2/2020/test/~WRL0003.tmp: Updated modification time in destination
2020/09/22 18:18:26 INFO  : folder1/folder2/2020/test/~WRD0002.tmp: Deleted
2020/09/22 18:18:26 INFO  : folder1/folder2/2020/test/~WRL0003.tmp: Removed from cache
2020/09/22 18:19:17 INFO  : Cleaned the cache: objects 12 (was 12), total size 488.712k (was 488.175k)

hello and welcome to the forum,

not sure we can call this a bug yet.

  • you would need to post a debug log
  • good idea to update rclone.

Thank you, I really forgot to check for a new version.
With the version below the issue is no longer present.

rclone v1.53.1
- os/arch: windows/amd64
- go version: go1.15

glad the problem is solved.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.