Let everyone see my mounted folders


#1

I installed rclone on my NAS (Synology DS716+II) , and use rclone mount to Google Drive.

Everything is fine for administrators, but for non-administrators, the mounted folders are invisible (FTP/WebDav).
I tried to check the mounted folders by [ stat -c ‘%a’ ] , the result is 755 ; it’s weird because it seems to be readable for everyone,

I want my mounted folders readable for everyone (read only), how should I do?
is --allow-other command ok for this case?


#2

FUSE has restrictions above the permissions - it will be limited to the user that ran rclone mount unless you use --allow-other.

If you want it to be read only then use the --read-only flag. That will make it read only for all users though - there isn’t a way to do something for administrators and something for normal users in rclone.


#3

Thank you very much!
My Google Drive folders have been mounted already (with no flags),
If I want to use the flags on the mounted folders , should I fusermount them?
Is it possible to plus the flags on the mounted folders?

I’m wondering how to change the attributes of mounted folders ;
fusermount and mount them again, or just use mount command with flags again?
Thank you :slight_smile:


#4

You’ll have to unmount them and run the mounts again with the new flags. As far as I know you can’t apply flags with FUSE filesystems after they are mounted.


#5

I unmounted and mounted again with these flags ( --allow-other --dir-cache-time 168h --buffer-size 64M ) , everything is fine, streaming videos, viewing the mounted folders for non-administrators…

Thank you , it’s really helpful :+1: