JottaCloud mount point w/ connection strings

What is the problem you are having with rclone?

I am using connection strings to perform remote control commands to JottaCloud. I am trying to perform commands on 3 different internal JottaCloud drives (Archive, Shared, and Sync) by changing the mountpoint param, however I am only able to access files on the default Archive drive. For example, if I try to perform an operations/list command on the 3 drives, I get the list of files in the Archive drive for all 3. Here is how I am specifying the fs's for the 3 drives:

:jottacloud,token='{***}',type='jottacloud',configVersion='1',mountpoint='Archive',device='Jotta'
:jottacloud,token='{***}',type='jottacloud',configVersion='1',mountpoint='Sync',device='Jotta'
:jottacloud,token='{***}',type='jottacloud',configVersion='1',mountpoint='Shared',device='Jotta'

The response from an operations/list command is the exact same for all 3 fs's.

What is your rclone version (output from rclone version)

1.55.1

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu

Which cloud storage system are you using? (eg Google Drive)

JottaCloud

The command you were trying to run (eg rclone copy /tmp remote:tmp)

operations/list

{
  fs: ":jottacloud,token='{***}',type='jottacloud',configVersion='1',mountpoint='Archive',device='Jotta'",
  remote: <path>
}

A log from the command with the -vv flag

Nothing is logged, the requests come back successfully for each mountpoint, but only return data from the Archive drive.

For info:

I tested on command-line, and switching mountpoint='Archive' with mountpoint='Sync' gives me different - and correct - result.

rclone lsd ":jottacloud,token='{\"access_token\":\"***...}',configVersion=1,mountpoint=Archive,device=Jotta:"

(the type='jottacloud' is implied, but including it does not make a difference)

Hmm, I tried removing the type param and I am still getting the same results when I change the mountpoint. Can you try running an operations/list command through the remote control using a connection string?

I have no experience with rc functionality, but I just tried it - and can confirm your results.

First started a "server process":

rclone rcd --rc-no-auth

Then running a "client process":

rclone rc operations/list fs=":jottacloud,token='{\"access_token\":...\"}',configVersion=1,mountpoint=Sync,device=Jotta:" remote=/ opt="{\"recurse\": true}"

Repeating with different value for the mountpoint parameter still returns the content of the original mountpoint. It is always the first command that decides what mountpoint are used for all following commands.

Got it. So is this a bug or expected behavior?

I don't know... Hopefully someone who do will join in. :crossed_fingers:

1 Like

Found a sort of workaround... If you set any of the options to a different value in the connection strings, then I think it works as you expected. E.g. include ,md5_memory_limit=11M in one of them and ,md5_memory_limit=12M in the other... :expressionless:

The issue is that the code checks if any of the options are overridden, in which case it does the detected overridden config - adding ... suffix to name logic, but the mountpoint, device etc are not considered to be options and therefore differences are not detected as "overridden config".

I suggest you create an issue for it. I think it is something that should be fixed, but if it is just a limitation then at least it should be documented.