JottaCloud migration to Drive

Hi all,

just wondering if anyone is using Jottacloud...... I have been using them... but am in the process of moving back to Google.....

getting files out has proven to be a right royal pain in the proverbial..... I have a second machine on which I have setup a profile for google and Jottacloud. Using these I am using a Rclone sync to copy data from Jotta to google. this was working ok.... there seems to be a download limit for Jottacloud (about 70-80GB) before a token is no longer valid. SOOOOOOO it has taken a while but I have moved 7.5TB out of 11TB ..... catch is now I can't refresh the token..... I have tried two different machines and all get is:

Failed to create file system for "jotta:": couldn't get account info: failed to get endpoint url: error 401: Token mismatch! (Unauthorized)

I have refreshed the token multiple times..... just wondering if something has changed in the Jotta world that Rclone can no longer get a new token??

any help would be great...... so I can finish my migration!!!

See this part:

As I think that's your item since you setup a 2nd machine.

Ive done that.... that's what I meant about the token.... I say yes and refresh the token..... that's the part that I think is failing.....

unless I am missing something silly!!!! :slight_smile:

So you went through and created a separate DeviceID and secret for each machine? Just want to make sure we are saying the same thing.

via rclone?? yes.....

on the server hosting media I have Jotta mounted to a folder.... this is working etc....

on a different server I have a Clean install.... installed rclone and then ran a rclone config... and a generated a new token

Meaning on this part, you hit y?

Do you want to create a machine specific API key?

Rclone has it's own Jottacloud API KEY which works fine as long as one only uses rclone on a single machine. When you want to use rclone with this account on more than one machine it's recommended to create a machine specific API key. These keys can NOT be shared between machines.

y) Yes
n) No
y/n> y
Your Jottacloud password is only required during setup and will not be stored.

correct!!! :slight_smile:

and if I answer No to the next question (non-standard....) you get the error I posted

Hmm, I don't see anything obvious. I'd add your info to this issue and see if we can get more details on it.

And someone just added this item:

interesting..... I will say its relieving its not just me..... but that's not helpful over all.... that is the same issue I am seeing... or at least appears to be!! :slight_smile:

I wonder if Jotta have changed anything!!

The Jottacloud remote is using the Jottacloud-API unofficially. There is no documentation or any kind of "stable" use of it. They change it from time to time and then we have to catch up.
And now it seems they have changed the way the tokens are handled and this cause trouble for anyone using Jottacloud with rclone.
Unfortunately you will have to wait for some one to step in and fix this. Until then it's considered broken and you would need to use the official Jottacloud tools.

ok cool.... glad its not just me!!!.....

back to the old way.... download in batches.... de-compress.... and then upload to google!!!

not ideal.... but will work!!!

just an FYI to anyone interested.... Jottacloud seems to perform perfectly well.... I have around 12TB there and no performance issues or anything.... its just limited on access (need to use native client, no webdav or other etc...) and may be a little slow on downloads..... my needs have changed a little (outside of just media) and well moving back!!

Contact jottacloud, maybe they can unlock your api.

We've just merged a fix for the jottacloud api - please try the latest beta

Phew, what a relief! Just discovered that my scheduled sync to Jotta started failing as of yesterday, with:

... failed to get endpoint url: error 401: Token mismatch! (Unauthorized)

Having just tried it with this morning's Beta I can confirm that the issue seems to be resolved, al least in my case.


1 Like

from my tests it seems to be working!!!

I'll have to update to the Beta in my prod server too..... I am still running Jotta there till I migrate!!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.