Inserting variable names in dir path

What is the problem you are having with rclone?

Unable to SET variable name without using dummy character in position 0.

What is your rclone version (output from rclone version)

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

N:>cd rclone

N:\rclone>rclone version
rclone v1.52.0

  • os/arch: windows/amd64
  • go version: go1.14.3


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows Server 2012, 64bit

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

 SET YYYY=%2020%
 ECHO It's %YYYY% today

N:\rclone>SET YYYY=020

N:\rclone>ECHO It's 020 today
It's 020 today

Press any key to continue . . .

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

Welcome. I don't understand the question and how this relates to rclone?

set YYYY=2020
mkdir c:\test\%YYYY%
echo 0 > c:\test\%YYYY%\file.txt
dir c:\test\%YYYY%
1 Like

Wow, my bad. Thank you.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.