I dont know what am I doing wrong, while installing rclone + gdrive + plex. (Detailed steps)

Ive tried everything, but I still cant see the error. Im using Fedora 25.
So I follow the following steps, and I can see the ecrypted files from gdrive, but Plex wont read them.

    1. rclone config
      I create a remote, called “remote”, and associate it to GDRIVE.
    1. Configuring encryption
      rclone config
  • -name: secret
  • -crypt
  • -remote : remote:
  • -standard encryption
  • -i generate a password
    1. So Ive 2 remotes, ones (Name: remote, type:drive), and the other is (Name: secret, type:crypt)
    1. Im gonna upload One Movie, located in /root/Movies to my googledrive account, so I use:
      rclone sync /root/Movies secret:
    1. I go to my google drive web interface, and check if theres something uploaded. And yes, theres an encrypted file (the movie i just uploaded)
    1. I proceed to mount the drive, to check it using Plex.
    1. `rclone mount --allow-other secret: /root/googledrive &`

I mount the drive in my googledrive folder which i created in root

    1. df
      Theres listed (filesystem: secret: , mounted on: /root/googledrive)
    1. I navigate to /root/googledrive with cd , and i do a ls -a
      There i find my movie decrypted. Everything seems fine.
    1. I check again google drive web interface, theres still a ENCRYPTED file.
    1. I go to plex, and set up the route to /root/googledrive , and it finds nothing.


EDIT: SOLVED, I GAVE UID 0 TO PLEX USER, i know its not right, but it works

Looks all good, i think.
To *10: Of course it is still encrypted. why should it be decrypted?
To *11: Most likely a permissions issue. Under which user is plex running? Which user mounted the drive?

The file should still be encrypted in the google web interface.

Plex only shows directories when you add a library. So if there is just a mp4 or whatever it will look empty. Did you actually add /root/googledrive to plex and see if it started to index anything?

I mounted the drive using ROOT user, however my plex user has root permissions.

When i add it , it justs says Media Scan completed, extra information may be still downloading from the internet. And nothing happens
Ive there just one mkv vile

There are many reasons for this and you’re not providing a lot of infromation about your Plex setup.

  1. Did you create a library?
  2. In your library, is a Movie or TV Show library?
  3. You pointed your library to /root/googledrive?
  4. How did you name your file?

solved giving uid0 permissions to PLEX user, i know its not right, but it works