I am trying to sync google drive with mega but is very slow - help to increase speed

rclone sync "gdrive:/Upload/Family" "megaz:/Family" --fast-list --transfers=40 --checkers=40 --tpslimit=10 --drive-chunk-size=1M --max-backlog 200000 --verbose --stats=30s

the code i have used is this to sync 33gb of google drive to mega. but i am seeing the speed is very slow it is showing like a single file will finish 46hours and it is only 200mb.

rclone version is what?

Try starting with defaults as you have a lot of transfers and checkers going on.

rclone sync "gdrive:/Upload/Family" "megaz:/Family" --fast-list --verbose --stats=30s

This would be terrible for Gdrive upload speed, but it should be irrelevant as long as you are transferring Gdrive-->Mega and not the other way around, so not applicable to this spesific problem. I mention it as an apropo for later use. Just don't use this when uploading to your Gdrive (should be 64M at least IMO unless you have very low RAM).

You may want to enable debug output with -vv (replaces --verbose) and watch for a bit to see if you get a butt-load of server-errors or something. Definitely try it with default transfers/checkers like Animosity suggests.

The mega upload code is quite inefficient unfortunately - this might explain the problem.

Are you transferring large files?