Http:// issue

Hi, I am trying to setup a VPS running Ubuntu with Plex. I am following a step by step guide and I am now on the part where I install rclone so I can upload the movies to amazon cloud drive. I can not figure out any way to open the authorization link. The guide says to use this: w3m It has worked before on another server I made but now i can get it to work. I’ve tried it in several different browsers as well yet none will load this link. Thanks for your help.

Sounds like you need to use one of the remote setup methods on this page

I’ve tried that. Still won’t work. The link won’t open like it doesn’t exist or is down.

It works for me that link. Here is the info copied here

Configuring rclone on a remote / headless machine

Some of the configurations (those involving oauth2) require an
Internet connected web browser.

If you are trying to set rclone up on a remote or headless box with no
browser available on it (eg a NAS or a server in a datacenter) then
you will need to use an alternative means of configuration. There are
two ways of doing it, described below.

Configuring using rclone authorize

On the headless box

Remote config
Use auto config?
 * Say Y if not sure
 * Say N if you are working on a remote or headless machine
y) Yes
n) No
y/n> n
For this to work, you will need rclone available on a machine that has a web browser available.
Execute the following on your machine:
	rclone authorize "amazon cloud drive"
Then paste the result below:

Then on your main desktop machine

rclone authorize "amazon cloud drive"
If your browser doesn't open automatically go to the following link:
Log in and authorize rclone for access
Waiting for code...
Got code
Paste the following into your remote machine --->
<---End paste

Then back to the headless box, paste in the code

client_id = 
client_secret = 
y) Yes this is OK
e) Edit this remote
d) Delete this remote

Configuring by copying the config file

Rclone stores all of its config in a single configuration file. This
can easily be copied to configure a remote rclone.

So first configure rclone on your desktop machine

rclone config

to set up the config file.

Find the config file by running rclone -h and looking for the help for the --config option

$ rclone -h
      --config="/home/user/.rclone.conf": Config file.

Now transfer it to the remote box (scp, cut paste, ftp, sftp etc) and
place it in the correct place (use rclone -h on the remote box to
find out where).