How to copy files from GCS path with no alphanumeric characters

I am using rclone to sync files from a GCS bucket to S3. It is working fine when I run something like:

rclone sync gcs-remote:gs-bucket/subdir aws-remote:s3-bucket

However, one of the GCS bucket has a subdir named "/". When I copy it's GCS path from the console, it pastes as "gs-bucket//subdir"

However, when I run rclone on this path, no files gets copied. No errors appear either. I tried adding quotes like:

rclone sync gcs-remote:"gs-bucket//subdir" aws-remote:s3-bucket

which still didn't work. I also tried syncing at bucket level and excluding other subdir like this:

rclone sync gcs-remote:"gs-bucket" aws-remote:s3-bucket --exclude /other-subdir/**

but it still skips over the files in "/". Any advice?

That happens you delete and don't use the help and support template to post a question.

I don't think rclone will be able to copy this path at the moment - it expects keys to be valid file system paths and unfortunately a // isn't a valid filesystem path.

I have an idea for a workaround but it isn't implemented yet.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.