How to choose each NIC in Windows 10?

i se that there is a language issue here.

for testing the new --bind flag, create a very simple rclone command.
once you have the --bind flag working, add all the other parts of the rclone mount command.

I understand what you are trying to say. I don't think you understand me.

I'm on a Windows 10 x64 environment, mount is the default, and rclone cache is the default. In other words, rclone is the environment where the cache should be mounted. Because of this, many options are almost needed.

I understood what I said to reduce the options and only test --bind. Of course I did. Not mounted. Unmounted tests are meaningless.

The latest version of ForceBindIP is v1.32, and there is also a 64-bit version. However, this does not work on Windows 10 x64.

Perhaps it intercepts the commands in ws2_32.dll, but I guess Windows 7 and Windows 10 are different.

Similarly, Windows 10 seems to have something to do with rclone's --bind option.

I'm wondering if you're using a Windows 10 and using a task scheduler instead of nssm.

And register python script with scheduler?
I am wondering if you are applying ForceBindIP like this.

Could you please share your script?

Is 220.xxx.xxx.xxx attached directly to your computer? Do you see that address in the results of ipconfig?

Can you paste the results of ipconfig?

The contents of the rclone.conf file on Windows 10 x64 are as follows:

[testid_cache]
type = cache
remote = testid:
chunk_size = 100M
info_age = 12h
chunk_total_size = off
db_path = E:\temp\rclone\testid_backend
chunk_path = E:\temp\rclone\testid_chunk
chunk_clean_interval = 1h0m0s
read_retries = 10
workers = 16
chunk_no_memory = false
rps = 10
writes = true
tmp_upload_path = E:\temp\rclone\testid_upload
tmp_wait_time = 15s
db_wait_time = 1s


was running rclone by registering a service with NSSM. But I was applying wrong.
NSSM allows only 300 characters. However, the options below are about 800 characters long. The option of more than 300 characters was not applied.

mount testid: Y: --config=D:\rclone\rclone.conf --allow-other --no-checksum --no-modtime --allow-non-empty --cache-chunk-path=E:\temp\rclone\testid_chunk --cache-db-path=E:\temp\rclone\testid_backend --cache-tmp-upload-path=E:\temp\rclone\testid_upload --cache-dir=E:\temp\rclone\testid_cache
--bwlimit 100M --buffer-size 0M --bind 220.xxx.xxx.xxx --attr-timeout 1s --drive-chunk-size 256M --max-read-ahead=64M --cache-chunk-size=100M --cache-total-chunk-size=off --cache-info-age=12h --cache-db-purge --cache-chunk-clean-interval=1h --cache-workers=16 --cache-rps=10 --tpslimit=10 --tpslimit-burst=10 --low-level-retries=10 --vfs-cache-mode=full --vfs-cache-max-age=24h --vfs-read-chunk-size=128M -vfs-read-chunk-size-limit=off --log-level INFO --log-file=E:\temp\rclone\logs\rclone_X.log


Except for overlapping rclone.conf, I've dieted as follows:

mount testid: Y: --config=D:\rclone\Y\rclone.conf --allow-other --no-checksum --no-modtime --allow-non-empty --fast-list --cache-dir=E:\temp\rclone\testid_cache
--bwlimit 100M --buffer-size 0 --bind 220.xxx.xxx.xxx --drive-chunk-size 256M --max-read-ahead=64M --cache-db-purge --tpslimit=10 --tpslimit-burst=10 --low-level-retries=10 --vfs-cache-mode=full --vfs-cache-max-age=24h --vfs-read-chunk-size=128M --vfs-read-chunk-size-limit=off --log-level INFO --log-file=E:\temp\rclone\logs\rclone_Y.log


I want to put the rest of the options in rclone.conf as well. What should I do?

  1. put that long rclone command into a .cmd file and use nssm to run that .cmd file.
  2. i use task manager, using the gui.
  3. try to run forcebindip as system user, using the task scheduler.

thank you. Thanks to you, half seems successful.
The problem seems to be that the command is cut off after 300 characters.

D:\rclone>D:\rclone\X\rclone.exe mount testid: X: --config=D:\rclone\rclone.conf --allow-other --no-checksum --no-modtime --allow-non-empty --cache-chunk-path=E:\temp\rclone\testid_chunk --cache-db-path=E:\temp\rclone\testid_backend --cache-tmp-upload-path=E:\temp\rclone\testid_upload --cache-dir=E:\temp\rclone\testid_cache
The service rclone has been started.
The service rclone has been stopped.

D:\rclone>--bwlimit 100M --buffer-size 0M --bind 220.xxx.xxx.xxx --attr-timeout 1s --drive-chunk-size 256M --max-read-ahead=100M --cache-chunk-size=100M --cache-total-chunk-size=off --cache-info-age=12h --cache-db-purge --cache-chunk-clean-interval=1h --cache-workers=16 --cache-rps=10 --tpslimit=10 --tpslimit-burst=10 --low-level-retries=10 --vfs-cache-mode=full --vfs-cache-max-age=24h --vfs-read-chunk-size=128M -vfs-read-chunk-size-limit=off --log-level INFO --log-file=E:\temp\rclone\logs\rclone_X.log

D:\rclone>

The same is true if you create it with .cmd.
Because ... No logs are created, no cache files are created.

Linux allows you to set rclone.conf like this, but on Windows it is difficult to find a manual on how to handle things other than the default options.

@ncw Please help me.

  1. it is hard to read the graphic snippet, better to pase the command as text into the forum port.
  2. are you running the rclone mount inside a .cmd file?
  3. most of my rclone command are over 300 characters.
    for example:

C:\data\rclone\scripts\rclone.exe sync "b:\firefox_20191026.112905\data\C\firefox\6f95nzz4.default" wasabiwest01:en07\firefox\rclone\backup\ --stats=0 --backup-dir=wasabiwest01:en07\firefox\rclone\archive\20191026.112905\ --log-level=DEBUG --log-file=C:\data\rclone\logs\firefox\20191026.112905\firefox_20191026.112905_rclone.log

  1. read this page https://rclone.org/docs/

2 . read this link https://rclone.org/docs/#config-config-file

  1. --config=e:\path.to.file\rclone.config

for example...

In Linux, in rclong.conf
--vfs-read-chunk-size = 128M
can add options like this

How do put it in rclong.conf for Windows?
vfs-read-chunk-size = 128M
Can put it like this?

It's about the same option, but splits between failure and success.

[Failed]
D:\rclone\Y\rclone.exe mount testid: Y: --config=D:\rclone\rclone.conf --allow-other --no-checksum --no-modtime --allow-non-empty --cache-chunk-path=E:\temp\rclone\testid_chunk --cache-db-path=E:\temp\rclone\testid_backend --cache-tmp-upload-path=E:\temp\rclone\testid_upload --cache-dir=E:\temp\rclone\testid_cache
--bwlimit 100M --buffer-size 0M --bind 220.xxx.xxx.xxx --attr-timeout 1s --drive-chunk-size 256M --max-read-ahead=100M --cache-chunk-size=100M --cache-total-chunk-size=off --cache-info-age=12h --cache-db-purge --cache-chunk-clean-interval=1h --cache-workers=16 --cache-rps=10 --tpslimit=10 --tpslimit-burst=10 --low-level-retries=10 --vfs-cache-mode=full --vfs-cache-max-age=24h --vfs-read-chunk-size=128M -vfs-read-chunk-size-limit=off --log-level INFO --log-file=E:\temp\rclone\logs\rclone_X.log

[Success]
D:\rclone\Y\rclone.exe mount testid: Y: --config=D:\rclone\rclone.conf --bwlimit 100M --buffer-size 0M --bind 220.xxx.xxx.xxx --attr-timeout 1s --drive-chunk-size 256M --max-read-ahead=100M --cache-chunk-size=100M --cache-info-age=12h --cache-db-purge --cache-chunk-clean-interval=1h --cache-workers=16 --cache-rps=10 --tpslimit=10 --tpslimit-burst=10 --low-level-retries=10 --vfs-cache-mode=full --vfs-cache-max-age=24h --vfs-read-chunk-size=128M --vfs-read-chunk-size-limit=off --log-level INFO --log-file=E:\temp\rclone\logs\rclone_X.log --allow-other --no-checksum --no-modtime --allow-non-empty --cache-chunk-path=E:\temp\rclone\testid_chunk --cache-db-path=E:\temp\rclone\testid_backend --cache-tmp-upload-path=E:\temp\rclone\testid_upload --cache-dir=E:\temp\rclone\testid_cache

It just changed the order of the options. @ncw Dear developer~:) Do you know this cause?

set root=c:\data\rclone\scripts
set RCLONE_CONFIG_PASS=.......
set RCLONE_CONFIG=%root%\rclone.conf
set source=wasabiwest01:en07
set drive=y:
set logfile=--log-level=DEBUG --log-file=%root%\rr\other\mount\logfile.txt 

%root%\rclone.exe mount %source% %drive% %logfile%

another way to shorten your rclone mount command is to
change
E:\temp\rclone\testid_cache
to
E:\t\r\tc

change
E:\temp\rclone\logs\rclone_X.log
to
E:\t\r\l\X.log

as the error message states, you cannot have a command line that starts with --bwlimit.
the start of a command line must be a internal command like dir or external command like rclone.exe

the command prompt knows nothing about --bwlimit, that is just a flag for the command rclone.exe

@asdffdsa @ncw Thank you so much.

You are right. I haven't typed Enter but it has been entered. thank you. I solved it.

Glad you got it working - excellent debugging @asdffdsa

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.