How to "automatize" rclone?

Isn't this referred to "upload" bandwidth? I am talking about HDD read utilization

so you tried my suggestion and you found it did not help?

you might also try to tweak ```
--checkers int Number of checkers to run in parallel. (default 8)

Both Linux and Windows have user accounts (this means admin accounts also) and system-accounts. If you run scripts under cron or task-scheduler you may be using the system account (or at least have the option to do so). This counts as a separate user - and by default in rclone each user has their own independent config. So for example the system accounts config could be blank after you set up rclone on your own account. If you ran the webGUI under the system account that might explain why it appears to have no configuration... that's what I meant.

If in doubt - you can force rclone to always use the same config file by moving rclone.conf into the same folder as the exe. This will override the default and force that config to be used regardless of which user runs the program. I find this useful myself since my computer is not used by anyone other than me anyway - and probably the same is true for a lot of powerusers.

Hope that explains it :slight_smile:

--checksum also requires to hash local files if you use it - so use this "as needed" for exactly the same reason as you don't necessarily want to always use --track-renames. In fact --track-renames implies --checksum

Checksum is nice (although hardly required) for moves for example, since it hashes once and then it's off the drive. It's not so good for automatically recurring syncs of large amounts of data - since it will then hash everything every time (to compare files using hashes), even if it doesn't end up transferring them in the end - leading to a lot of disk-activity.

I also want to say that checksum is not needed for a safe transfer. There are several layers of error correction at work even if you aren't checksumming - so for just normal movement of data where -track-renames isn't needed and modtimes of files haven't been corrupted or something then you can just skip it. That will make rclone only read as much as it actually needs to transfer. (ie. very little on a recurring sync with little change having occured).

1 Like

Understood, so
Sync & move -> use --checksum
Copy -> Don't use --checksum
Server-side -> --track-renames
And --track-renames implies --checksum, so it's pointless to use --checksum if I already use --track-renames right?

Thanks :slight_smile:

Yeah I already moved rclone.conf into the same folder as the .exe, I also used a "command line" (don't remember what) to set the rclone.conf in the same folder

Yes, I run scripts with task-scheduler and I use SYSTEM, but I try to open the GUI "manually" and it doesn't work

I've seen that in the CMD I get an error if I try to do something in the GUI..

I tried adding --rc-no-auth but nothing changed

I would not recommend it for sync. Not unless it is sync on a fairly small amount of data - or one that is not synced often. Because you will have to hash (and thus fully read) all files you sync, even if you don't end up needing any transfers.

Yes exactly. if you --track-renames it will do nothing extra to add --checksum. That will be enabled automatically because --track-renames MUST have it to do what you asked. (at least in current implementation of --track-renames).

--config string                        Config file. (default "$HOME/.config/rclone/rclone.conf")

But this is temporary and only affects that ONE command...

you can check where rclone.conf file is located by running
rclone config file
as the same user you will run rclone from.

Hmm ok. Looks like the UI actually launches, but you say there is nothing in the config?
The way you launched it and where you have rclone.conf stored means there should be no way that configs are confused between users. That is good to have eliminated as a possibility.
Unfortuantely that also means I am not sure what the problem is...
if you go to the "explorer" page, use 1-side-by-side" and try to input your remote name, do you see your files? Or does nothing happen?

Should look something like this if it works:

--rc-no-auth should in theory fix this, but I wonder if this is just a bug, because I think I had the same issue. if I actually set a user/password everything worked, so you may want to try that.

If this does not help you solve the problem then I think you would perhaps have the best success searching for one of the active webGUI development/feedback threads because then you can talk to people who actually know the internals of the webGUI much better than me.

If all else fails you can also open an issue ticket if you think it is a real bug in the code (and there definitely are some as webGUI is relatively new to rclone). Use "new issue" here if needed:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.