How do I reset RCLONE_CONFIG_PASS on Windows?

I was playing around with RCLONE_CONFIG_PASS and had the idea to remove it in Registry manually. After I returned it there, both manually and through the setx command, rclone doesn't recognize it anymore. I already rebooted my computer. rclone just says "Couldn't decrypt configuration, most likely wrong password." whenever I try to run a command.


i used to hide the rclone password in the registry, it worked well but now use a different technique.

please provide a more detailed explanation of exactly what you are doing, as we cannot see into your computer

First I did was execute this command on cmd setx RCLONE_CONFIG_PASS [mypassword]. Then, I tested if I could run rclone commands without entering the password of my config. I wasn't prompted to enter my password. As I've said, I was experimenting with this feature, so I removed my config password via setx RCLONE_CONFIG_PASS "". Again, that proved to work as I was asked to enter my password when I tried to run an rclone command. I put my password back again after that. My last experiment was tinkering around with RCLONE_CONFIG_PASS in the actual Registry. I removed its entry there and ran an rclone command. As expected, rclone asked me to enter my password. I ran setx RCLONE_CONFIG_PASS [mypassword] to get my password back in Registry and it did appear when I checked, but this time, rclone couldn't recognize it anymore. I tried setx and manually adding entries on Registry but rclone doesn't seem to detect RCLONE_CONFIG_PASS. I guess deleting the entry manually caused this problem. What do I do now?

Maybe you are fully aware of it, but remember that setx does not set the environment of your currently running process, i.e. the Command Prompt you run it from. You must either start a new Command Prompt, or run an additional command to also set it in the environment of the current process:


From Microsoft's documentation:

Setx provides the only command-line or programmatic way to directly and permanently set system environment values.

I could run rclone commands without password prompts even though I had closed the cmd where I ran the setx command.

But not from the same cmd, was my point.

Problem solved!

  1. Remove RCLONE_CONFIG_PASS in Registry either by manually removing it there or through cmd.
  2. Unencrypt configuration
  3. Encrypt configuration BUT with a different password than before. I think this problem occurred because I just kept using the same password over and over while I was trying to do a trial and error with removing and adding RCLONE_CONFIG_PASS and encrypting and unencrypting my config.
  4. Set RCLONE_CONFIG_PASS. I used setx RCLONE_CONFIG_PASS <mypassword> on cmd.
1 Like

this might have added to the confusion.
[Because SETX writes variables to the master environment in the registry, edits will only take effect when a new command window is opened - they do not affect the current CMD or PowerShell session.]

I don't think so. I closed cmd multiple times during the whole trial and error and even restarted my computer. The only time rclone stopped giving me "couldn't decrypt configuration, most likely wrong password" was when I changed the password I was using for my config.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.