How can I restrict rclone within a specific directory in Nextcloud?

What is the problem you are having with rclone?

No problem.
I am using rclone with Nextcloud.
Now I want to restrict rclone into a directory like in Google drive.
How Can I do that?

See the rclone command with this post.
You will see that this can be done using 'target'
But I want all files from rclone to go to a specific folder by default.

How can I do that?

Thanks for reading.

What is your rclone version (output from rclone version)

rclone v1.56.2

  • os/version: arch (64 bit)
  • os/kernel: 5.10.70-1-lts (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.1
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy /some/dir remote:target

The rclone config contents with secrets removed.

I don't think this is needed.

A log from the command with the -vv flag

This is a how to question.

hello and welcome to the forum,

if you want rclone to default to a specific folder, use an alias remote -

type = alias
remote = remote:target

and use it like so
rclone copy /some/dir remote-folder:

perhaps, you might be able to hardcode the folder into the remote like so.

type = webdav
url =

Thank you.
This worked.
I am using the hardcode method.

good to know that the hardcode method work.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.