High error rate & slow upload speed when uploading to Google Drive

Hi, I have created my own client id for uploading to Google Drive. This issue has persisted for more than a week, I have been struggling to find a solution. I thought I was being ratelimited but my usage is well under the quota limit as shown in the screenshot below, the credential was fine a week ago until I found out that I have to be verified? I don't have to be verified since many months ago, it only happened this week.

Credentials landing page:



Traffic by response code:

What version are you running?
What command are you running?
Can you share a debug log of the command with "-vv" on it?

Version: rclone v1.43.1(I know it's outdated for more than a year, I'm contacting the seedbox provider to update rclone)

Command: rclone move --checksum --transfers 3 --checkers 3 --tpslimit 100 --tpslimit-burst 10 --fast-list --max-transfer 750G -P

Debug log:

The upload speed is horrible, the seedbox provider said their network has no issue, they suggested that the issue is from Google Drive's end.

If you are running mainly big files, you can try using more transfers to see if that helps.

The other option is using larger drive chunk sizes for the uploads.


Depending on your memory, you can use 128M / 256 / 512 / 768 or whatever is available. I have a ton of memory so I use a 1G.

I'd remove all of those and just use the defaults once you get updated to the current version.

Just FYI, you don't need to wait on the seedbox provider. rclone is a self-contained binary which you can download and start using immediately. You don't need any root access as long as you can download files.

Why did I not think of this, thanks mate!

Speed has improved tremendously, it averages 23 MB/s while checking(is checking actually downloading?) but I think it still can be improved, I was getting much higher speed two weeks ago.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.